aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2020-11-27 17:53:42 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2020-11-27 17:53:42 +0100
commit090ccec102abff80582f5a32ff8980143696d697 (patch)
tree31609f49a3bccf3649e258d311bbe61a308875e4
parent125b2d87783c487d947ba61692285ccd1400df2b (diff)
downloadguix-090ccec102abff80582f5a32ff8980143696d697.tar
guix-090ccec102abff80582f5a32ff8980143696d697.tar.gz
gnu: Add slimevolley.
* gnu/packages/games.scm (slimevolley): New variable.
-rw-r--r--gnu/packages/games.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 3b288cc8b8..038379ae62 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -8284,6 +8284,39 @@ and cooperative.")
;; developers.
(license (list license:gpl2+ license:lgpl2.1+))))
+(define-public slimevolley
+ (package
+ (name "slimevolley")
+ (version "2.4.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://download.tuxfamily.org/slime/"
+ "slimevolley_" version ".tar.gz"))
+ (sha256
+ (base32 "1pi60zjpx95mfdkrbwf4cbzy5lv4v5qrljvgck46qca78i9g9g46"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:tests? #f ;no test
+ ;; Work around build failure: "error adding symbols: DSO
+ ;; missing from command line".
+ #:configure-flags (list "-DCMAKE_EXE_LINKER_FLAGS=-lm")))
+ (native-inputs
+ `(("gettext" ,gettext-minimal)))
+ (inputs
+ `(("sdl" ,(sdl-union (list sdl sdl-image sdl-net sdl-ttf)))))
+ (home-page "https://slime.tuxfamily.org/")
+ (synopsis "Unrealistic 2D volleyball simulation")
+ (description
+ "Slime Volley is a 2D arcade-oriented volleyball simulation, in
+the spirit of some Java games of the same name.
+
+Two teams, 1-3 players each, try to be the first to get 10 points.
+This happens when the one ball touches the floor on the other side of
+the net. There can be 1 to 8 balls in game. Once one ball touches
+the ground, the set ends and all balls are served again.")
+ (license license:gpl3+)))
+
(define-public slingshot
(package
(name "slingshot")