aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2021-06-27 10:48:32 +0100
committerChristopher Baines <mail@cbaines.net>2021-07-02 00:01:14 +0100
commitfd549750d9ab23a0505aeb4c03e1299e860a4f16 (patch)
tree27134562e0f804326a3c6ef0c3828133e0f18482
parent5b35276140c57caa33657591efe53934c3d33830 (diff)
downloadguix-fd549750d9ab23a0505aeb4c03e1299e860a4f16.tar
guix-fd549750d9ab23a0505aeb4c03e1299e860a4f16.tar.gz
gnu: grub-efi: Only enable the stack protector on x86_64-linux.
Follow up to 018f95094153660e3041ec160718f0bda286a3dc, as gcc on aarch64-linux doesn't seem to support -mstack-protector-guard=global. Fixes <https://bugs.gnu.org/49088>. * gnu/packages/bootloaders.scm (grub-efi)[arguments]: Only add "--enable-stack-protector" to #:configure-flags when system is x86_64-linux.
-rw-r--r--gnu/packages/bootloaders.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/bootloaders.scm b/gnu/packages/bootloaders.scm
index e83f21ea63..742992a119 100644
--- a/gnu/packages/bootloaders.scm
+++ b/gnu/packages/bootloaders.scm
@@ -303,7 +303,11 @@ menu to select one of the installed operating systems.")
((#:tests? _ #f) #f)
((#:configure-flags flags ''())
`(cons* "--with-platform=efi"
- "--enable-stack-protector" ; EFI-only for now
+ ,@(if (string-prefix? "x86_64"
+ (or (%current-target-system)
+ (%current-system)))
+ '("--enable-stack-protector") ; EFI-only for now
+ '())
,flags))
((#:phases phases)
`(modify-phases ,phases