aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBruno Victal <mirai@makinata.eu>2023-10-09 21:06:02 +0100
committerLudovic Courtès <ludo@gnu.org>2024-08-31 10:42:08 +0200
commiteeb9b9b6ac31185737a15e4b0c8dc600e4a610eb (patch)
treeeb2e18f2d412f5e846561de5d3ae6d9a55eb568a
parent489e40d745d401acfed4b56b6a7814a4b926bbed (diff)
downloadguix-eeb9b9b6ac31185737a15e4b0c8dc600e4a610eb.tar
guix-eeb9b9b6ac31185737a15e4b0c8dc600e4a610eb.tar.gz
gnu: docbook2x: Split documentation.
* gnu/packages/docbook.scm (docbook2x)[arguments]<#:phases>: Add 'move-doc phase. [outputs]: Add 'doc output. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
-rw-r--r--gnu/packages/docbook.scm7
1 files changed, 7 insertions, 0 deletions
diff --git a/gnu/packages/docbook.scm b/gnu/packages/docbook.scm
index d203867802..635310941d 100644
--- a/gnu/packages/docbook.scm
+++ b/gnu/packages/docbook.scm
@@ -883,11 +883,18 @@ Detect the differences in markup between two SGML files.
"<bridgehead renderas=\"sect2\">"))
;; Force a new autoreconf run.
(delete-file "configure")))))
+ (outputs '("out" "doc"))
(build-system gnu-build-system)
(arguments
(list
#:phases
#~(modify-phases %standard-phases
+ (add-after 'install 'move-doc
+ (lambda _
+ (let* ((old (string-append #$output "/share/doc"))
+ (new (string-append #$output:doc "/share/doc")))
+ (mkdir-p (dirname new))
+ (rename-file old new))))
(add-after 'install 'wrap-programs
(lambda* (#:key inputs outputs #:allow-other-keys)
(let* ((programs