aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-07-02 05:20:49 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2021-07-02 07:14:10 +0200
commite6fd51a36ea1884c0ab56d24d41023594d4d2f3e (patch)
treefc2b26e940e1a413e70f459e722c2832b818cab7
parent26f31c7c9a3351b9c5675c63f2f1609ef27fd9a9 (diff)
downloadguix-e6fd51a36ea1884c0ab56d24d41023594d4d2f3e.tar
guix-e6fd51a36ea1884c0ab56d24d41023594d4d2f3e.tar.gz
gnu: vsftpd: Properly enable the SSL support.
* gnu/packages/ftp.scm (vsftpd)[arguments]: Remove (questionable?) "-lcrypt" from LDFLAGS. #define VSF_BUILD_SSL in a new 'build-SSL phase instead.
-rw-r--r--gnu/packages/ftp.scm9
1 files changed, 8 insertions, 1 deletions
diff --git a/gnu/packages/ftp.scm b/gnu/packages/ftp.scm
index 68424c1591..481863bf33 100644
--- a/gnu/packages/ftp.scm
+++ b/gnu/packages/ftp.scm
@@ -272,11 +272,18 @@ directory comparison and more.")
(arguments
`(#:make-flags
(list (string-append "CC=" ,(cc-for-target))
- "LDFLAGS=-lcap -lcrypt -lpam"
+ ;; vsf_findlibs.sh looks only for hard-coded {/usr,}/lib file names
+ ;; that will never exist on Guix. Manage libraries ourselves.
+ "LDFLAGS=-lcap -lpam"
"INSTALL=install -D")
#:tests? #f ; no test suite
#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'build-SSL
+ (lambda _
+ (substitute* "builddefs.h"
+ (("#undef (VSF_BUILD_SSL)" _ symbol)
+ (string-append "#define " symbol)))))
(add-after 'unpack 'append-make-flags
(lambda _
(substitute* "Makefile"