aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2021-04-04 23:00:27 -0400
committerTimothy Sample <samplet@ngyro.com>2022-03-19 13:33:07 -0600
commite42753fd862486a29e9b6da8fc105fba23d6318a (patch)
tree8c3c3407772203f2a05414c8c46ad4112ce10f55
parent97a5819643a045b7cc68e80fd2fc05ed4eabf0d0 (diff)
downloadguix-e42753fd862486a29e9b6da8fc105fba23d6318a.tar
guix-e42753fd862486a29e9b6da8fc105fba23d6318a.tar.gz
gnu: sed-mesboot0: Remove package.
* gnu/packages/commencement.scm (sed-mesboot0): Remove variable. (%boot-tcc-inputs): Remove 'sed-mesboot0'.
-rw-r--r--gnu/packages/commencement.scm44
1 files changed, 0 insertions, 44 deletions
diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index d0bac512a3..49b7defffb 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -881,54 +881,10 @@ $MES -e '(mescc)' module/mescc.scm -- \"$@\"
;; FIXME: no compressing gzip yet
(delete 'compress-documentation))))))
-(define sed-mesboot0
- ;; The initial sed.
- (package
- (inherit sed)
- (name "sed-mesboot0")
- (version "1.18")
- (source (origin
- (method url-fetch)
- (uri (string-append "mirror://gnu/sed/sed-"
- version ".tar.gz"))
- (sha256
- (base32
- "1hyv7i82jd0q18xcql51ylc8jwadp3gb3irgcqlis3v61p35jsv2"))))
- (supported-systems '("i686-linux" "x86_64-linux"))
- (inputs '())
- (propagated-inputs '())
- (native-inputs (%boot-tcc0-inputs))
- (arguments
- `(#:implicit-inputs? #f
- #:guile ,%bootstrap-guile
- #:parallel-build? #f
- #:configure-flags '("CC=tcc")
- #:make-flags '("CC=tcc" "extra_objs=" "DEFS=-D HAVE_BCOPY")
- #:strip-binaries? #f ; no strip yet
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'scripted-patch
- (lambda _
- (let* ((out (assoc-ref %outputs "out"))
- (bash (assoc-ref %build-inputs "bash"))
- (shell (string-append bash "/bin/bash")))
- (substitute* "configure"
- (("/bin/sh") shell)))))
- (replace 'check
- (lambda _
- (invoke "./sed" "--version")))
- (replace 'install
- (lambda _
- (let* ((out (assoc-ref %outputs "out"))
- (bin (string-append out "/bin")))
- (install-file "sed" bin)))))))))
-
(define (%boot-tcc-inputs)
`(("bash" ,bash-mesboot0)
("gzip" ,gzip-mesboot)
("patch" ,patch-mesboot)
- ("sed" ,sed-mesboot0)
- ;; Place lower than sed so we don't override it.
("gash-utils" ,gash-utils-boot)
("tcc" ,tcc-boot)
,@(alist-delete "tcc" (%boot-tcc0-inputs))))