aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@friendly-machines.com>2024-12-14 22:14:43 +0100
committerDanny Milosavljevic <dannym@friendly-machines.com>2024-12-14 22:14:43 +0100
commitca305f0716a71c28c5c40e9b6fb09195682f03dd (patch)
treead15e6bad3e3937871165f3c13ba77156b6f7f86
parent187a223dcbcf9357013bc4953ca81c0b91abe0f8 (diff)
downloadguix-ca305f0716a71c28c5c40e9b6fb09195682f03dd.tar
guix-ca305f0716a71c28c5c40e9b6fb09195682f03dd.tar.gz
gnu: python-pytest-flakefinder: Fix build.
* gnu/packages/python-check.scm (python-pytest-flakefinder)[native-inputs]: Add python-wheel, python-setuptools. Change-Id: Ic43963f7877901923f266cc89d07380bb0f66bfd
-rw-r--r--gnu/packages/python-check.scm8
1 files changed, 5 insertions, 3 deletions
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index 6230f62784..faff95a762 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -51,6 +51,7 @@
#:use-module (gnu packages openstack)
#:use-module (gnu packages perl)
#:use-module (gnu packages python-build)
+ #:use-module (gnu packages python-science)
#:use-module (gnu packages python-web)
#:use-module (gnu packages python-xyz)
#:use-module (gnu packages qt)
@@ -247,6 +248,7 @@ it adds to the Pytest command line interface (CLI).")
(sha256
(base32 "03iy80xlkpgzjs2kxa9rrj8dbnp9awyhpcl3hy8fgf5x40cjlhg2"))))
(build-system pyproject-build-system)
+ (native-inputs (list python-wheel python-setuptools))
(propagated-inputs (list python-pytest))
(home-page "https://github.com/dropbox/pytest-flakefinder")
(synopsis "Pytest plugin for finding flaky tests")
@@ -2299,7 +2301,7 @@ them using any Python VM with basically no runtime overhead.")
(define-public python-nptyping
(package
(name "python-nptyping")
- (version "2.0.0")
+ (version "2.5.0")
(source (origin
(method git-fetch) ;pypi only contains a binary wheel
(uri (git-reference
@@ -2308,7 +2310,7 @@ them using any Python VM with basically no runtime overhead.")
(file-name (git-file-name name version))
(sha256
(base32
- "0839mcrv5jljq9k9124ssnl1hc1inbxwlwjk72imabsbqssjy9rb"))))
+ "0m6iq98qi9pl5hcc5k99bvy5w293vrlsdnimxl020i60rfnihgl7"))))
(build-system python-build-system)
(arguments
`(#:phases
@@ -2324,7 +2326,7 @@ them using any Python VM with basically no runtime overhead.")
python-setuptools
python-typeguard
python-wheel))
- (propagated-inputs (list python-numpy python-typing-extensions))
+ (propagated-inputs (list python-numpy python-typing-extensions python-pandas-stubs))
(home-page "https://github.com/ramonhagenaars/nptyping")
(synopsis "Type hints for Numpy")
(description "This package provides extensive dynamic type checks for