aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-06-26 12:33:21 +0200
committerRicardo Wurmus <rekado@elephly.net>2023-06-26 12:34:35 +0200
commitc3446354a9b31e61729e5f811d6be6ede535bd77 (patch)
treef4763611c66502915a848bc481aa31b515715589
parent75f24d40fdb21dc97e4f4771cfcd8e7571485db4 (diff)
downloadguix-c3446354a9b31e61729e5f811d6be6ede535bd77.tar
guix-c3446354a9b31e61729e5f811d6be6ede535bd77.tar.gz
gnu: Add r-rnaturalearth.
* gnu/packages/cran.scm (r-rnaturalearth): New variable.
-rw-r--r--gnu/packages/cran.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index ba81580258..3aa8efb936 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -17782,6 +17782,27 @@ Helene Touzet and Jean-Stephane Varre, 2007, Algorithms Mol Biol:2, 15.
Touzet and Varre (2007).")
(license license:gpl2)))
+(define-public r-rnaturalearth
+ (package
+ (name "r-rnaturalearth")
+ (version "0.3.3")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "rnaturalearth" version))
+ (sha256
+ (base32
+ "0cji6hpcpkrsx615627z9dgk0zf78l2nnj3x5kkkpj9lvsm5gj6m"))))
+ (properties `((upstream-name . "rnaturalearth")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-httr r-jsonlite r-sf r-sp r-terra))
+ (native-inputs (list r-knitr))
+ (home-page "https://cran.r-project.org/package=rnaturalearth")
+ (synopsis "World map data from Natural Earth")
+ (description
+ "This package facilitates mapping by making natural earth map data from
+@url{https://www.naturalearthdata.com/} more easily available to R users.")
+ (license license:expat)))
+
(define-public r-rncl
(package
(name "r-rncl")