aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-07-02 08:18:32 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2021-07-02 08:20:25 +0200
commitc19d29c983d1081f8ecb162dbaf2b57992589a6c (patch)
tree4844bc84d242494609cc77b4af32a44156ed3794
parentc01cce97591eb9f180c98e61b573226d7b7de6e4 (diff)
downloadguix-c19d29c983d1081f8ecb162dbaf2b57992589a6c.tar
guix-c19d29c983d1081f8ecb162dbaf2b57992589a6c.tar.gz
gnu: phodav: Fix udev rules directory.
Since commit da7a5e359761b156a632988a19fca0b6b289485a (e)udev is actually found triggering the installation of phodav's udev rules. That's great, except that it uses (e)udev's 'udevdir' pkg-config variable for that, which is of course not writable. * gnu/packages/gnome.scm (phodav)[arguments]: Add a new 'fix-udev-rules-directory phase.
-rw-r--r--gnu/packages/gnome.scm10
1 files changed, 8 insertions, 2 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 76513c3e48..57fa3cc75f 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -1167,13 +1167,19 @@ Library reference documentation.")
(arguments
`(#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'fix-udev-rules-directory
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (rules (string-append out "/lib/udev/rules.d")))
+ (substitute* "data/meson.build"
+ (("udev\\.get_pkgconfig_variable\\('udevdir'\\)")
+ (format #f "'~a'" rules))))))
(add-before 'check 'start-virtual-dir-server
;; The same server when started by tests/virtual-dir returns an
;; unexpected status (4 instead of 200) and fails a test. It is
;; unclear why starting it manually here makes it pass.
(lambda _
- (system "tests/virtual-dir-server &")
- #t)))))
+ (system "tests/virtual-dir-server &"))))))
(native-inputs
`(("docbook-xml" ,docbook-xml-4.3)
("gettext" ,gettext-minimal)