aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-06-30 20:02:32 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-06-30 20:02:32 +0300
commitb7d70aeb0b5fd595bcbb59b61e513f1291f45575 (patch)
tree6544566a81b2edcb1ee21c21f26871c9ca24d200
parente8e1dd2439d9834c062a254c60d897434e9b3f20 (diff)
downloadguix-b7d70aeb0b5fd595bcbb59b61e513f1291f45575.tar
guix-b7d70aeb0b5fd595bcbb59b61e513f1291f45575.tar.gz
gnu: tor: Update to 0.4.6.6.
* gnu/packages/tor.scm (tor): Update to 0.4.6.6. [source]: Remove patch. * gnu/packages/patches/tor-fix-build-with-gcc-7.patch: Remove file. * gnu/local.mk (dist_patch_DATA): Remove it.
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/patches/tor-fix-build-with-gcc-7.patch30
-rw-r--r--gnu/packages/tor.scm5
3 files changed, 2 insertions, 34 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 6b9202cba1..b197ec55f9 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1758,7 +1758,6 @@ dist_patch_DATA = \
%D%/packages/patches/tk-find-library.patch \
%D%/packages/patches/tla2tools-build-xml.patch \
%D%/packages/patches/tlf-support-hamlib-4.2+.patch \
- %D%/packages/patches/tor-fix-build-with-gcc-7.patch \
%D%/packages/patches/transcode-ffmpeg.patch \
%D%/packages/patches/transmission-honor-localedir.patch \
%D%/packages/patches/ttf2eot-cstddef.patch \
diff --git a/gnu/packages/patches/tor-fix-build-with-gcc-7.patch b/gnu/packages/patches/tor-fix-build-with-gcc-7.patch
deleted file mode 100644
index 5481695a63..0000000000
--- a/gnu/packages/patches/tor-fix-build-with-gcc-7.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-From 810c0616d59809b89f5144d4afdbf70391df7a7f Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Alexander=20F=C3=A6r=C3=B8y?= <ahf@torproject.org>
-Date: Thu, 10 Jun 2021 20:04:13 +0000
-Subject: [PATCH] Fix compilation on OpenSUSE.
-
-This patch fixes a build error with GCC 7.x which doesn't seem to accept
-const int's as constants in macro initialization.
-
-See: tpo/core/tor#40410
----
- src/feature/dirclient/dirclient.c | 3 +--
- 1 file changed, 1 insertion(+), 2 deletions(-)
-
-diff --git a/src/feature/dirclient/dirclient.c b/src/feature/dirclient/dirclient.c
-index 74c6452061..a2b20621a0 100644
---- a/src/feature/dirclient/dirclient.c
-+++ b/src/feature/dirclient/dirclient.c
-@@ -1907,8 +1907,7 @@ dir_client_decompress_response_body(char **bodyp, size_t *bodylenp,
- /* If we're pretty sure that we have a compressed directory, and
- * we didn't manage to uncompress it, then warn and bail. */
- if (!plausible && !new_body) {
-- const int LOG_INTERVAL = 3600;
-- static ratelim_t warning_limit = RATELIM_INIT(LOG_INTERVAL);
-+ static ratelim_t warning_limit = RATELIM_INIT(60 * 60);
- log_fn_ratelim(&warning_limit, LOG_WARN, LD_HTTP,
- "Unable to decompress HTTP body (tried %s%s%s, on %s).",
- description1,
---
-GitLab
-
diff --git a/gnu/packages/tor.scm b/gnu/packages/tor.scm
index 2d9aac1924..e4f16f6caa 100644
--- a/gnu/packages/tor.scm
+++ b/gnu/packages/tor.scm
@@ -56,15 +56,14 @@
(define-public tor
(package
(name "tor")
- (version "0.4.6.5")
+ (version "0.4.6.6")
(source (origin
(method url-fetch)
(uri (string-append "https://dist.torproject.org/tor-"
version ".tar.gz"))
(sha256
(base32
- "1yacd7h7wg8n6wwrjmx2g9xjj24kj08j5sai9g7fm4cp1m73avbv"))
- (patches (search-patches "tor-fix-build-with-gcc-7.patch"))))
+ "04ifi18cj4cw5lhfzgfrrc42j7qqdmbvxq24xlhj0dsmljdih8rl"))))
(build-system gnu-build-system)
(arguments
`(#:configure-flags