aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-11-29 15:54:03 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 21:01:37 +0000
commitaa8a25221f29b837506d01edb37f7b0f6ae8e6a0 (patch)
tree125c523f09c20e9107bf7348836a995e4f5b90e0
parenta41604d754d8decaf99734478cdc051d84574cb6 (diff)
downloadguix-aa8a25221f29b837506d01edb37f7b0f6ae8e6a0.tar
guix-aa8a25221f29b837506d01edb37f7b0f6ae8e6a0.tar.gz
gnu: python-greenlet: Update to 3.1.1.
* gnu/packages/python-xyz.scm (python-greenlet): Update to 3.1.1. [build-system]: Swap to pyproject-build-system. [arguments]<test-flags>: Deselect one failing test. <phases>: Add 'build-extensions. [native-inputs]: Add python-objgraph, python-pytest, python-psutil, python-setuptools, and python-wheel. Change-Id: I50c80f329890fc922dcc8310083dfa2ee1ee03c4
-rw-r--r--gnu/packages/python-xyz.scm26
1 files changed, 23 insertions, 3 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index e1e6875132..8854d7655f 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -21497,14 +21497,34 @@ library. It can be used to act both as a TFTP client or TFTP server.")
(define-public python-greenlet
(package
(name "python-greenlet")
- (version "2.0.1")
+ (version "3.1.1")
(source
(origin
(method url-fetch)
(uri (pypi-uri "greenlet" version))
(sha256
- (base32 "0rqgxp1fai0fcyv46nd1389mxvk3ccixgdkwws70xnk08ib05rj2"))))
- (build-system python-build-system)
+ (base32 "0rsla5f2vgc6g450fziprjy98vf2fwbz6zjx8x37kpvavdnarqsc"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list
+ ;; AssertionError: 'Exception' not found in ''
+ #:test-flags
+ #~(list (string-join
+ (list "--deselect=src/greenlet/tests/test_greenlet.py"
+ "TestGreenlet"
+ "test_dealloc_catches_GreenletExit_throws_other")
+ "::"))
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'check 'build-extensions
+ (lambda _
+ (invoke "python" "setup.py" "build_ext" "--inplace"))))))
+ (native-inputs
+ (list python-objgraph
+ python-pytest
+ python-psutil
+ python-setuptools
+ python-wheel))
(home-page "https://greenlet.readthedocs.io/")
(synopsis "Lightweight in-process concurrent programming")
(description