aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJean-Pierre De Jesus DIAZ <jean@foundation.xyz>2024-05-23 13:47:04 +0200
committerLudovic Courtès <ludo@gnu.org>2024-11-20 23:34:55 +0100
commita6d34a6fe161fd7f1bd1aa5609bb6027d69495d2 (patch)
tree03659b1802a46178d79aab514afb0f2bb842ba0f
parent53ef4bf53775cf80959000667c5bdb7f4d7b6232 (diff)
downloadguix-a6d34a6fe161fd7f1bd1aa5609bb6027d69495d2.tar
guix-a6d34a6fe161fd7f1bd1aa5609bb6027d69495d2.tar.gz
gnu: ocaml-sedlex: Use G-Expressions.
* gnu/packages/ocaml.scm (ocaml-sedlex): Use G-expressions. Change-Id: I1dd8b9e1cefef90ff4cdcc592f5ad3d735a5081b Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/ocaml.scm40
1 files changed, 19 insertions, 21 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 9d29105cdb..0b92279878 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -3720,27 +3720,25 @@ and consumable.")
"1z8mmk1idh9hjhh2b9rp5b1h8kmzcxhagqkw0pvxn6ykx1brskq1"))))
(build-system dune-build-system)
(arguments
- `(#:tests? #f ; no tests
- #:package "sedlex"
- #:phases
- (modify-phases %standard-phases
- (add-before 'build 'copy-resources
- (lambda* (#:key inputs #:allow-other-keys)
- (with-directory-excursion "src/generator/data"
- ;; Newer versions of dune emit an error if files it wants to
- ;; build already exist. Delete the dune file so dune doesn't
- ;; complain.
- (delete-file "dune")
- (for-each
- (lambda (file)
- (copy-file (assoc-ref inputs file) file))
- '("DerivedCoreProperties.txt" "DerivedGeneralCategory.txt"
- "PropList.txt")))
- #t))
- (add-before 'build 'chmod
- (lambda _
- (for-each (lambda (file) (chmod file #o644)) (find-files "." ".*"))
- #t)))))
+ (list #:tests? #f ; no tests
+ #:package "sedlex"
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'build 'copy-resources
+ (lambda* (#:key inputs #:allow-other-keys)
+ (with-directory-excursion "src/generator/data"
+ ;; Newer versions of dune emit an error if files it wants to
+ ;; build already exist. Delete the dune file so dune doesn't
+ ;; complain.
+ (delete-file "dune")
+ (for-each
+ (lambda (file)
+ (copy-file (assoc-ref inputs file) file))
+ '("DerivedCoreProperties.txt" "DerivedGeneralCategory.txt"
+ "PropList.txt")))))
+ (add-before 'build 'chmod
+ (lambda _
+ (for-each (lambda (file) (chmod file #o644)) (find-files "." ".*")))))))
(propagated-inputs
(list ocaml-gen ocaml-ppxlib ocaml-uchar))
;; These three files are needed by src/generator/data/dune, but would be