aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-12-01 10:02:41 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 21:01:39 +0000
commit892fb103007104a0c4ce9a81dba8e9c4a984aad3 (patch)
tree138a6d984c93e82afd785a4801cd1c3e6b13ec8e
parent66be2df8411a876b0fd306c8789519349c69bd0e (diff)
downloadguix-892fb103007104a0c4ce9a81dba8e9c4a984aad3.tar
guix-892fb103007104a0c4ce9a81dba8e9c4a984aad3.tar.gz
gnu: python-flake8-quotes: Update to 3.4.0.
* gnu/packages/python-xyz.scm (python-flake8-quotes): Update to 3.4.0. [build-system]: Swap to pyproject-build-system. [native-inputs]: Add python-pytest, python-setuptools, and python-wheel. Change-Id: I37446ade937f2f0cc0ea1c12acf3e176971964ad
-rw-r--r--gnu/packages/python-xyz.scm11
1 files changed, 7 insertions, 4 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index e0d48367e7..e94212dc17 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -15543,15 +15543,18 @@ lints.")
(define-public python-flake8-quotes
(package
(name "python-flake8-quotes")
- (version "3.2.0")
+ (version "3.4.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "flake8-quotes" version))
(sha256
- (base32
- "0ph5s6lxgpzz4an0ax6s5xjqypqmngwr5b1i0h9pqhzghplic49z"))))
- (build-system python-build-system)
+ (base32 "0v1762x0819xqha7w4l4hh66bpi82imgiib8pvmd78hhnwplkn5a"))))
+ (build-system pyproject-build-system)
+ (native-inputs
+ (list python-pytest
+ python-setuptools
+ python-wheel))
(propagated-inputs
(list python-flake8))
(home-page "https://github.com/zheller/flake8-quotes/")