aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 16:41:50 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 19:42:12 +0200
commit7fb8654f8f8874eef26c601588740d155a79a97c (patch)
tree892bba5738d784af10835c7a6df8110fee53185d
parent7b8af069003f35a6dce1e2f6343617586de14124 (diff)
downloadguix-7fb8654f8f8874eef26c601588740d155a79a97c.tar
guix-7fb8654f8f8874eef26c601588740d155a79a97c.tar.gz
gnu: Add texlive-principia.
* gnu/packages/tex.scm (texlive-principia): New variable.
-rw-r--r--gnu/packages/tex.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 1e3b0e8e10..a68a038a4a 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -5560,6 +5560,25 @@ of all rational roots is implemented via such macros.")
deduction calculi, sequent-like calculi, and similar.")
(license license:gpl3+)))
+(define-public texlive-principia
+ (package
+ (name "texlive-principia")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/principia/"
+ "tex/latex/principia/")
+ (base32
+ "1pq9plcp0zp5a4nhz80kbkhbg00axp10p20r1bwq4ck7giwci3jf")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/principia")
+ (synopsis "Notations for typesetting the @emph{Principia Mathematica}")
+ (description
+ "This package supports typesetting the Peanese notation in Volume I of
+Whitehead and Russell's 1910 @emph{Principia Mathematica}.")
+ (license license:lppl1.3c)))
+
(define-public texlive-bibtex8
(package
(name "texlive-bibtex8")