aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-11-05 20:17:18 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:19:02 +0000
commit43e5eafbdd387aac6a0488ea3b39177adbe1aeb6 (patch)
treea3dd06ce33829b85b2fa506600dcc48d03a5cbf3
parenta8b1af6cbc479430835e9ff2828588cd1b50120a (diff)
downloadguix-43e5eafbdd387aac6a0488ea3b39177adbe1aeb6.tar
guix-43e5eafbdd387aac6a0488ea3b39177adbe1aeb6.tar.gz
gnu: nikola: Fix build.
* gnu/packages/python-xyz.scm (nikola): Fix build. [build-system]: Swap to pyproject-build-system. [arguments]<phases>: Use default check phase. Keep all tests. [native-inputs]: Remove python-coverage and python-flake8; add nss-certs-for-test, python-setuptools, and python-wheel. Change-Id: I74a754ce9f3b2fc4400c4f92ec976a6815cdb511
-rw-r--r--gnu/packages/python-xyz.scm24
1 files changed, 8 insertions, 16 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 6769cb6589..a1ec0775ae 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -36562,7 +36562,14 @@ these linters: @code{pycodestlye}, @code{pyflakes}")
(uri (pypi-uri "Nikola" version))
(sha256
(base32 "1h96y4sfypp2fbqxa8xrqch5f7r3srm2ly222k9w2n143h2spx4m"))))
- (build-system python-build-system)
+ (build-system pyproject-build-system)
+ (native-inputs
+ (list nss-certs-for-test
+ python-freezegun
+ python-pytest
+ python-pytest-cov
+ python-setuptools
+ python-wheel))
(propagated-inputs
(list python-babel
python-blinker
@@ -36585,21 +36592,6 @@ these linters: @code{pycodestlye}, @code{pyflakes}")
python-toml
python-unidecode
python-yapsy))
- (native-inputs
- (list python-coverage
- python-flake8
- python-freezegun
- python-pytest
- python-pytest-cov))
- (arguments
- (list
- #:phases
- #~(modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- (invoke "pytest" "tests" "--no-cov"
- "-k" "not test_compiling_markdown[hilite]")))))))
(home-page "https://getnikola.com/")
(synopsis "Modular, fast and simple static website and blog generator")
(description "Nikola generates static websites and blogs. Out of the box,