aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-11 00:22:11 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-11 14:40:02 +0200
commit3985f60be7d9c23ff7005564cd92ae16539b19d7 (patch)
treeaf0d74191366ba5c48cd3a36a637b4ebdd987439
parentda9085549c9042aab1b97c371d425a02a2bbe9df (diff)
downloadguix-3985f60be7d9c23ff7005564cd92ae16539b19d7.tar
guix-3985f60be7d9c23ff7005564cd92ae16539b19d7.tar.gz
gnu: Add texlive-mwcls.
* gnu/packages/tex.scm (texlive-mwcls): New variable.
-rw-r--r--gnu/packages/tex.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 4a9a1de009..ee311f6ff2 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -6579,6 +6579,34 @@ related to multiobjective optimisation, multiobjective evolutionary
algorithms, multicriteria decision making and similar fields.")
(license license:lppl)))
+(define-public texlive-mwcls
+ (package
+ (name "texlive-mwcls")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/mwcls/" "source/latex/mwcls/"
+ "tex/latex/mwcls/")
+ (base32
+ "1pj1m08gh5zsahvzan6wq9v0lnir9zb4qvgkadsl6jm9ia8990yn")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/mwcls")
+ (synopsis "Polish-oriented document classes")
+ (description
+ "@code{mwcls} is a set of document classes for LaTeX designed with Polish
+typographical tradition in mind. The classes include: @code{mwart} (which is
+a replacement for @code{article}), @code{mwrep} (replacing @code{report}), and
+@code{mwbk} (replacing @code{book}).
+
+Most features present in standard classes work with @code{mwcls} classes.
+Some extensions/exceptions include: sectioning commands allow for second
+optional argument (it is possible to state different texts for running head
+and for TOC), new environments @code{itemize*} and @code{enumerate*} for lists
+with long items, page styles have variants for normal, opening, closing, and
+blank pages.")
+ (license license:lppl1.2+)))
+
(define-public texlive-naive-ebnf
(package
(name "texlive-naive-ebnf")