aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-11-29 10:33:39 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 21:01:36 +0000
commit372b1491a544871ae4b9c8f7d47123d51be8a876 (patch)
tree18f33319333677a605a8b38d37452c555d3426df
parent8da504bf236ae1e45068bf1249af7db1a94be4ef (diff)
downloadguix-372b1491a544871ae4b9c8f7d47123d51be8a876.tar
guix-372b1491a544871ae4b9c8f7d47123d51be8a876.tar.gz
gnu: python-flake8: Update to 7.1.1.
* gnu/packages/python-xyz.scm (python-flake8): Update to 7.1.1. Improve style. [srouce]: Swap to git checkout containing tests. [build-system]: Swap to pyrpoject-build-system. [home-page]: Fix it as GitLab link is dead. [propagated-inputs]: Remove python-entrypoints. [native-inputs]: Add python-setuptools and python-wheel. Change-Id: I6e0edd637469c516db90dd927b2d7eb6b96a5f5d
-rw-r--r--gnu/packages/python-xyz.scm35
1 files changed, 17 insertions, 18 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 640364e89b..9024137bed 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -15289,27 +15289,26 @@ complexity of Python source code.")
(define-public python-flake8
(package
(name "python-flake8")
- (version "4.0.1")
- (source (origin
- (method url-fetch)
- (uri (pypi-uri "flake8" version))
- (sha256
- (base32
- "03c7mnk34wfz7a0m5zq0273y94awz69fy5iww8alh4a4v96h6vl0"))))
- (build-system python-build-system)
- (arguments
- `(#:phases (modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- (invoke "pytest" "-v")))))))
+ (version "7.1.1")
+ (source
+ (origin
+ (method git-fetch) ; no tests data in PyPi package
+ (uri (git-reference
+ (url "https://github.com/pycqa/flake8")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0qbj2m1ljyvpnncnkbm1cscy726c1if4n2c9ysfpmd2zm88rj87a"))))
+ (build-system pyproject-build-system)
+ (native-inputs
+ (list python-pytest
+ python-setuptools
+ python-wheel))
(propagated-inputs
- (list python-entrypoints
- python-mccabe
+ (list python-mccabe
python-pycodestyle
python-pyflakes))
- (native-inputs (list python-pytest))
- (home-page "https://gitlab.com/pycqa/flake8")
+ (home-page "https://flake8.pycqa.org/en/latest/")
(synopsis "The modular source code checker: pep8, pyflakes and co")
(description
"Flake8 is a wrapper around PyFlakes, pep8 and python-mccabe.")