aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkku Korkeala <markku.korkeala@iki.fi>2024-11-26 17:19:15 +0200
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-17 12:21:53 +0000
commit00bcb384da5c69e96b689f3d01a9ebe46b7b9fd7 (patch)
tree38d55dfcecf48592863d0645aac0f26e0ce0ce9e
parent946f76302394e685c1534550a774777e068b492c (diff)
downloadguix-00bcb384da5c69e96b689f3d01a9ebe46b7b9fd7.tar
guix-00bcb384da5c69e96b689f3d01a9ebe46b7b9fd7.tar.gz
gnu: Add python-jsonpath-ng.
* gnu/packages/python-xyz.scm (python-jsonpath-ng): New variable. Change-Id: Ie7835850bc137f3bbaea19f01d42b01ba0f5458e Co-authored-by: Sharlatan Hellseher <sharlatanus@gmail.com> Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
-rw-r--r--gnu/packages/python-xyz.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index eea388ca89..0381d8fdc1 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -158,6 +158,7 @@
;;; Copyright © 2024 Peter Kannewitz <petre-vps@posteo.net>
;;; Copyright © 2024 Aaron Covrig <aaron.covrig.us@ieee.org>
;;; Copyright © 2024 Evgeny Pisemsky <mail@pisemsky.site>
+;;; Copyright © 2024 Markku Korkeala <markku.korkeala@iki.fi>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -481,6 +482,32 @@ including arbitrary-length lists, records, mixed types, and missing data,
using NumPy-like idioms.")
(license license:bsd-3)))
+(define-public python-jsonpath-ng
+ (package
+ (name "python-jsonpath-ng")
+ (version "1.7.0" )
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "jsonpath-ng" version))
+ (sha256
+ (base32 "0g5bpq02pl9mv7mbqixvnagq8f9v0jab6wqmbxw9rxsz9vyzgxgn"))))
+ (build-system pyproject-build-system)
+ (native-inputs
+ (list python-pytest
+ python-setuptools
+ python-wheel))
+ (propagated-inputs
+ (list python-ply))
+ (home-page "https://github.com/h2non/jsonpath-ng")
+ (synopsis "JSONPath Next-Generation")
+ (description
+ "This package provides a final implementation of @code{JSONPath} for
+Python that aims to be standard compliant, including arithmetic and binary
+comparison operators, as defined in the original
+@url{http://goessner.net/articles/JsonPath/, JSONPath} proposal.")
+ (license license:asl2.0)))
+
(define-public python-xmldiff
(package
(name "python-xmldiff")