aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-02-19 18:04:37 +0100
committerRicardo Wurmus <rekado@elephly.net>2021-02-19 18:04:37 +0100
commitfceda92f8651cd7b527aec67fbeb49c9a4adffbc (patch)
tree9683ceee812508d2dd21ec10e493a62d66372d7d
parent0d9c9502694984a800be9df3bf6ed518c3ce2aca (diff)
downloadguix-fceda92f8651cd7b527aec67fbeb49c9a4adffbc.tar
guix-fceda92f8651cd7b527aec67fbeb49c9a4adffbc.tar.gz
gnu: Add perl-contextual-return.
* gnu/packages/perl.scm (perl-contextual-return): New variable.
-rw-r--r--gnu/packages/perl.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index ca754868d1..ea520fe65a 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -8912,6 +8912,28 @@ other OO languages like Python, Ruby, Java and Perl 6.")
its return value is going to be immediately used.")
(license license:perl-license)))
+(define-public perl-contextual-return
+ (package
+ (name "perl-contextual-return")
+ (version "0.004014")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/D/DC/DCONWAY/Contextual-Return-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0y4zf5qkpayp4kkg7lw9ydbbin1z99m6xvy02fgacjbfw4ai9zh9"))))
+ (build-system perl-build-system)
+ (propagated-inputs
+ `(("perl-want" ,perl-want)))
+ (home-page "https://metacpan.org/release/Contextual-Return")
+ (synopsis "Create context-sensitive return values")
+ (description "This module provides a collection of named blocks that allow
+a return statement to return different values depending on the context in
+which it is called.")
+ (license license:perl-license)))
+
(define-public perl-statistics-basic
(package
(name "perl-statistics-basic")