aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2019-11-01 13:52:59 -0400
committerTimothy Sample <samplet@ngyro.com>2019-11-20 20:48:17 -0500
commitf9d78c7f785db7a1e41e7dd49a36fc999c295ca2 (patch)
tree6cd125ebcaef9e25e59789b9e1c25dec2e1647e6
parent882b23e2392342bfae531dba4b7e5a380f5179d3 (diff)
downloadguix-f9d78c7f785db7a1e41e7dd49a36fc999c295ca2.tar
guix-f9d78c7f785db7a1e41e7dd49a36fc999c295ca2.tar.gz
gnu: Add ghc-base-compat-batteries.
* gnu/packages/haskell-xyz.scm (ghc-base-compat-batteries): New variable.
-rw-r--r--gnu/packages/haskell-xyz.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 9da282679e..f2363a655f 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -662,6 +662,39 @@ of base to a wider range of compilers, without requiring the use of CPP
pragmas in your code.")
(license license:bsd-3)))
+(define-public ghc-base-compat-batteries
+ (package
+ (name "ghc-base-compat-batteries")
+ (version "0.10.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://hackage.haskell.org/package/"
+ "base-compat-batteries/base-compat-batteries-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1vkhc639vqiv5p39jn1v312z32i7yk5q2lf0ap4jxl1v8p8wyp8p"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-base-compat" ,ghc-base-compat)))
+ (native-inputs
+ `(("ghc-hspec" ,ghc-hspec)
+ ("ghc-quickcheck" ,ghc-quickcheck)
+ ("hspec-discover" ,hspec-discover)))
+ (arguments
+ `(#:cabal-revision
+ ("1" "15sn2qc8k0hxbb2nai341kkrci98hlhzcj2ci087m0zxcg5jcdbp")))
+ (home-page "http://hackage.haskell.org/package/base-compat-batteries")
+ (synopsis "base-compat with extra batteries")
+ (description "This library provides functions available in later
+versions of @code{base} to a wider range of compilers, without requiring
+you to use CPP pragmas in your code. This package provides the same API
+as the @code{base-compat} library, but depends on compatibility
+packages (such as @code{semigroups}) to offer a wider support window
+than @code{base-compat}, which has no dependencies.")
+ (license license:expat)))
+
(define-public ghc-basement
(package
(name "ghc-basement")