aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-02-19 23:30:28 +0100
committerRicardo Wurmus <rekado@elephly.net>2021-02-19 23:35:04 +0100
commitf310b06685cb9b1f95150b24f3eed82ca280c1d2 (patch)
tree80578a4839e22e665295a749bb731839797318d1
parent96193caaa14e575cc2917d0fd7ca8c7499109635 (diff)
downloadguix-f310b06685cb9b1f95150b24f3eed82ca280c1d2.tar
guix-f310b06685cb9b1f95150b24f3eed82ca280c1d2.tar.gz
gnu: nanopolish: Fix script wrapping.
* gnu/packages/bioinformatics.scm (nanopolish)[arguments]: Fix wrap-programs phase. [inputs]: Add Guile for wrap-script; add bioperl and perl-getopt-long for Perl scripts.
-rw-r--r--gnu/packages/bioinformatics.scm22
1 files changed, 14 insertions, 8 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 7d5521e91d..c8ddf8e3d7 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -14249,18 +14249,24 @@ choosing which reads pass the filter.")
#t)))
(add-after 'install 'wrap-programs
(lambda* (#:key outputs #:allow-other-keys)
- (for-each (lambda (file)
- (wrap-program file `("PYTHONPATH" ":" prefix (,path))))
- (find-files "/share/nanopolish/scripts" "\\.py"))
- (for-each (lambda (file)
- (wrap-program file `("PERL5LIB" ":" prefix (,path))))
- (find-files "/share/nanopolish/scripts" "\\.pl"))
- #t)))))
+ (let ((pythonpath (getenv "PYTHONPATH"))
+ (perl5lib (getenv "PERL5LIB"))
+ (scripts (string-append (assoc-ref outputs "out")
+ "/share/nanopolish/scripts")))
+ (for-each (lambda (file)
+ (wrap-program file `("PYTHONPATH" ":" prefix (,pythonpath))))
+ (find-files scripts "\\.py"))
+ (for-each (lambda (file)
+ (wrap-script file `("PERL5LIB" ":" prefix (,perl5lib))))
+ (find-files scripts "\\.pl"))))))))
(inputs
- `(("eigen" ,eigen)
+ `(("guile" ,guile-3.0) ; for wrappers
+ ("eigen" ,eigen)
("hdf5" ,hdf5)
("htslib" ,htslib)
("perl" ,perl)
+ ("bioperl" ,bioperl-minimal)
+ ("perl-getopt-long" ,perl-getopt-long)
("python" ,python-wrapper)
("python-biopython" ,python-biopython)
("python-numpy" ,python-numpy)