aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Mikkelsen <petermikkelsen10@gmail.com>2017-03-20 20:17:09 +0100
committerLudovic Courtès <ludo@gnu.org>2017-03-23 12:59:03 +0100
commitdf7309fc6ed7ac15e50de22396e761ec0815c5e9 (patch)
treed718ecb0f86fed360b344e43d242b87ca047abbc
parent939b6b113bcd94c80fe50acdd634a2c0338b343c (diff)
downloadguix-df7309fc6ed7ac15e50de22396e761ec0815c5e9.tar
guix-df7309fc6ed7ac15e50de22396e761ec0815c5e9.tar.gz
gnu: Add ghc-code-page.
* gnu/packages/haskell.scm (ghc-code-page): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/haskell.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 2415881e8e..d48983a81a 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -9,6 +9,7 @@
;;; Copyright © 2015, 2016, 2017 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2016, 2017 David Craven <david@craven.ch>
;;; Copyright © 2017 Danny Milosavljevic <dannym@scratchpost.org>
+;;; Copyright © 2017 Peter Mikkelsen <petermikkelsen10@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -562,6 +563,27 @@ package.")
package.")
(license license:bsd-3)))
+(define-public ghc-code-page
+ (package
+ (name "ghc-code-page")
+ (version "0.1.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://hackage.haskell.org/package/code-page/code-page-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1491frk4jx6dlhifky9dvcxbsbcfssrz979a5hp5zn061rh8cp76"))))
+ (build-system haskell-build-system)
+ (home-page "https://github.com/RyanGlScott/code-page")
+ (synopsis "Windows code page library for Haskell")
+ (description "A cross-platform library with functions for adjusting
+code pages on Windows. On all other operating systems, the library does
+nothing.")
+ (license license:bsd-3)))
+
(define-public ghc-haddock-library
(package
(name "ghc-haddock-library")