aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMathieu Othacehe <othacehe@gnu.org>2021-02-22 14:45:59 +0100
committerMathieu Othacehe <othacehe@gnu.org>2021-02-22 14:47:26 +0100
commitdbc10e747428f31e5c84a2d9712af116ed6529b1 (patch)
tree4039e5ddbd74a774775d9f2e622fb5ac4d4ab3c5
parent011ec41c253b9ac772734b3dd5623655c644ed93 (diff)
downloadguix-dbc10e747428f31e5c84a2d9712af116ed6529b1.tar
guix-dbc10e747428f31e5c84a2d9712af116ed6529b1.tar.gz
gnu: cuirass: Update to 0.0.1-72.543e26a.
* gnu/packages/ci.scm (guile-mastodon-dev): New variable. (guile-mastodon-dev): Update to 0.0.1-72.543e26a. [inputs]: Use guile-mastodon-dev instead of guile-mastodon.
-rw-r--r--gnu/packages/ci.scm26
1 files changed, 22 insertions, 4 deletions
diff --git a/gnu/packages/ci.scm b/gnu/packages/ci.scm
index eac26a6dac..35bf285fab 100644
--- a/gnu/packages/ci.scm
+++ b/gnu/packages/ci.scm
@@ -47,9 +47,27 @@
#:use-module (gnu packages xml)
#:use-module (guix build-system gnu))
+(define-public guile-mastodon-dev
+ (let ((commit "88115d85221876b1baea4accb7c76995da32f479")
+ (revision "1"))
+ (package
+ (inherit guile-mastodon)
+ (name "guile-mastodon")
+ (version (git-version "0.0.1" revision commit))
+ (home-page "https://framagit.org/mothacehe/guile-mastodon.git")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url home-page)
+ (commit commit)))
+ (sha256
+ (base32
+ "04dgxliz9bmhn0f7h1n0dj0r5h0fzhg80nxl1rpbxh4zs1yw9qvj"))
+ (file-name (string-append name "-" version "-checkout")))))))
+
(define-public cuirass
- (let ((commit "3e6561740958ea06bf50f8086a4066b555beacc5")
- (revision "71"))
+ (let ((commit "543e26addc6e2304611e2feb8dd3a5a0646507b6")
+ (revision "72"))
(package
(name "cuirass")
(version (git-version "0.0.1" revision commit))
@@ -61,7 +79,7 @@
(file-name (git-file-name name version))
(sha256
(base32
- "1mrfjcfw9v7gpk4sp65jxfvikmdkxgkhwdjn29vjph04z82jh36z"))))
+ "01cxg0nwafzfg0phbv1b4cv24w7yaalkkdib3qfwf6jqagbfg85y"))))
(build-system gnu-build-system)
(arguments
'(#:modules ((guix build utils)
@@ -127,7 +145,7 @@
("guile-squee" ,guile-squee)
("guile-git" ,guile-git)
("guile-zlib" ,guile-zlib)
- ("guile-mastodon" ,guile-mastodon)
+ ("guile-mastodon" ,guile-mastodon-dev)
("mailutils" ,mailutils)
;; FIXME: this is propagated by "guile-git", but it needs to be among
;; the inputs to add it to GUILE_LOAD_PATH.