aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2021-02-19 10:18:45 +0100
committerGuillaume Le Vaillant <glv@posteo.net>2021-02-19 11:05:34 +0100
commitd6996fa05277f240b70b18c227419c371cfc737f (patch)
treefce9125be9193e347b8682d46b307532075913f1
parentd1bd22b9fb17e94931b7ebe23c6d9735b195442a (diff)
downloadguix-d6996fa05277f240b70b18c227419c371cfc737f.tar
guix-d6996fa05277f240b70b18c227419c371cfc737f.tar.gz
gnu: Add python-astroalign.
* gnu/packages/astronomy.scm (python-astroalign): New variable. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
-rw-r--r--gnu/packages/astronomy.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 98ef7b3a7e..b10b8013cb 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -841,6 +841,32 @@ of stand-alone functions and classes.")
license:expat
license:lgpl3+))))
+(define-public python-astroalign
+ (package
+ (name "python-astroalign")
+ (version "2.3.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "astroalign" version))
+ (sha256
+ (base32 "19qzv3552lgrd9qmj0rxs51wmx485hw04cbf76ds5pin85kfaiy1"))))
+ (build-system python-build-system)
+ (arguments
+ ;; TODO: (Sharlatan-20210213T162940+0000): I could not make tests run
+ `(#:tests? #f))
+ (inputs
+ `(("numpy" ,python-numpy)
+ ("scikit-image" ,python-scikit-image)
+ ("scipy" ,python-scipy)
+ ("sep" ,python-sep)))
+ (home-page "https://astroalign.readthedocs.io/")
+ (synopsis "Astrometric Alignment of Images")
+ (description
+ "ASTROALIGN is a python module that will try to align two stellar
+astronomical images, especially when there is no WCS information available.")
+ (license license:expat)))
+
(define-public python-skyfield
(package
(name "python-skyfield")