aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorqblade <qblade@protonmail.com>2021-02-21 01:44:05 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-02-21 01:44:05 +0100
commitc7be46b7d754cbf0d0526b5d8a9d1ecee64b6154 (patch)
tree0c096bc81c0958508749cd7618cf4dcc3729b9ac
parent5581279f79b394673c85b2761fb31dedba60b03c (diff)
downloadguix-c7be46b7d754cbf0d0526b5d8a9d1ecee64b6154.tar
guix-c7be46b7d754cbf0d0526b5d8a9d1ecee64b6154.tar.gz
gnu: Add vmtouch.
* gnu/packages/admin.scm (vmtouch): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/admin.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 8e2e64837a..a506b978f5 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -37,6 +37,7 @@
;;; Copyright © 2020 Morgan Smith <Morgan.J.Smith@outlook.com>
;;; Copyright © 2021 Zheng Junjie <873216071@qq.com>
;;; Copyright © 2021 Stefan Reichör <stefan@xsteve.at>
+;;; Copyright © 2021 qblade <qblade@protonmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -3888,6 +3889,38 @@ support forum. It runs with the @code{/exec} command in most IRC clients.")
(description "This package provides @code{udev} bindings for Python.")
(license license:lgpl2.1)))
+(define-public vmtouch
+ (package
+ (name "vmtouch")
+ (version "1.3.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/hoytech/vmtouch/")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "08da6apzfkfjwasn4dxrlfxqfx7arl28apdzac5nvm0fhvws0dxk"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("perl" ,perl)))
+ (arguments
+ `(#:tests? #f ; no tests
+ #:make-flags
+ (list
+ (string-append "CC=" ,(cc-for-target))
+ (string-append "PREFIX=" (assoc-ref %outputs "out")))
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure))))
+ (home-page "https://github.com/hoytech/vmtouch/")
+ (synopsis "Portable file system cache diagnostics and control")
+ (description
+ "vmtouch is a tool for learning about and controlling the file system
+cache of unix and unix-like systems.")
+ (license license:bsd-3)))
+
(define-public solaar
(package
(name "solaar")