aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMathieu Othacehe <othacehe@gnu.org>2021-02-22 09:30:52 +0100
committerMathieu Othacehe <othacehe@gnu.org>2021-02-22 10:23:04 +0100
commitbbd26d60edaeafab032ffa70e09633a621eeed92 (patch)
tree603ae3635c9249657a84c9e004620c6231df32e0
parent1443e2dd98ac6e2aecff726cfcc683dd9ba7240d (diff)
downloadguix-bbd26d60edaeafab032ffa70e09633a621eeed92.tar
guix-bbd26d60edaeafab032ffa70e09633a621eeed92.tar.gz
gnu: guile-mastodon: Build with Guile 3.0.
* gnu/packages/guile-xyz.scm (guile-mastodon)[source]: Modify configure.ac to add Guile 3.0 support. [native-inputs]: Add "emacs" and "texinfo". [inputs]: Use Guile 3.0 and Guile Json 4.0.
-rw-r--r--gnu/packages/guile-xyz.scm19
1 files changed, 15 insertions, 4 deletions
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 8d9126df44..cbec2081f0 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -1308,16 +1308,27 @@ Scheme by using Guileā€™s foreign function interface.")
(file-name (git-file-name name version))
(sha256
(base32
- "1vblf3d1bbwna3l09p2ap5y8ycvl549bz6whgk78imyfmn28ygry"))))
+ "1vblf3d1bbwna3l09p2ap5y8ycvl549bz6whgk78imyfmn28ygry"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ ;; Allow builds with Guile 3.0.
+ (substitute* "configure.ac"
+ (("^PKG_CHECK.*") "")
+ (("^GUILE_PKG.*")
+ "GUILE_PKG([3.0 2.2])\n"))
+ #t))))
(build-system gnu-build-system)
(native-inputs
`(("autoconf" ,autoconf)
("automake" ,automake)
- ("pkg-config" ,pkg-config)))
+ ("emacs" ,emacs-minimal)
+ ("pkg-config" ,pkg-config)
+ ("texinfo" ,texinfo)))
(inputs
- `(("guile" ,guile-2.2)
+ `(("guile" ,guile-3.0)
("gnutls" ,gnutls)
- ("guile-json" ,guile-json-1)))
+ ("guile-json" ,guile-json-4)))
(home-page "https://framagit.org/prouby/guile-mastodon")
(synopsis "Guile Mastodon REST API module")
(description "This package provides Guile modules to access the