aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVincent Legoll <vincent.legoll@gmail.com>2021-01-05 11:57:27 +0100
committerLeo Famulari <leo@famulari.name>2021-02-20 18:02:31 -0500
commitb78202f8a8db6e2c4e8563b9ecbb82f29efdfb57 (patch)
treeefd460af3300a628cc66ae961aaa96a43dcafc49
parent3c21da7c7984e3c05c023487cf649addbb134531 (diff)
downloadguix-b78202f8a8db6e2c4e8563b9ecbb82f29efdfb57.tar
guix-b78202f8a8db6e2c4e8563b9ecbb82f29efdfb57.tar.gz
gnu: Add libyang
* gnu/packages/networking.scm (libyang): New variable. Signed-off-by: Leo Famulari <leo@famulari.name>
-rw-r--r--gnu/packages/networking.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 804d4dce0c..ca8e5fa192 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -3519,6 +3519,33 @@ libraries and instead utilizing features provided by the Linux kernel to the
maximum extent possible.")
(license license:lgpl2.1+)))
+(define-public libyang
+ (package
+ (name "libyang")
+ (version "1.0.215")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/CESNET/libyang")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0mrs2ppmq77z8sbqgm2w0rl9bfgybd6bcxanakfww4chih6cy0dw"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:configure-flags
+ (list "-DENABLE_BUILD_TESTS=ON" "-DENABLE_LYD_PRIV=ON")))
+ (propagated-inputs `(("pcre" ,pcre)))
+ (native-inputs `(("cmocka" ,cmocka)
+ ("pkg-config" ,pkg-config)))
+ (home-page "https://github.com/CESNET/libyang")
+ (synopsis "YANG data modelling language library")
+ (description "libyang is a YANG data modelling language parser and toolkit
+written (and providing API) in C. Current implementation covers YANG 1.0 (RFC
+6020) as well as YANG 1.1 (RFC 7950).")
+ (license license:bsd-3)))
+
(define-public batctl
(package
(name "batctl")