aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2021-02-22 10:39:55 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-02-22 10:41:16 +0100
commitb4bbf3d1e9c86db8c418472b2f3a2622addd84dc (patch)
treed0e8f8335e52fb4620135d6d841a4186557b0afe
parent0e5bc144f35798b2a3d3336ee5cd040efde5bf85 (diff)
downloadguix-b4bbf3d1e9c86db8c418472b2f3a2622addd84dc.tar
guix-b4bbf3d1e9c86db8c418472b2f3a2622addd84dc.tar.gz
gnu: Rename ghc-nixfmt into nixfmt
* gnu/packages/haskell-xyz.scm (ghc-nixfmt): Move to... * gnu/packages/haskell-apps.scm (nixfmt): ... here. This is a followup to 703ccd583611b6efa689b7a2d1daf35d6cd83c35.
-rw-r--r--gnu/packages/haskell-apps.scm30
-rw-r--r--gnu/packages/haskell-xyz.scm30
2 files changed, 30 insertions, 30 deletions
diff --git a/gnu/packages/haskell-apps.scm b/gnu/packages/haskell-apps.scm
index a6fb33c31b..54266cd8bb 100644
--- a/gnu/packages/haskell-apps.scm
+++ b/gnu/packages/haskell-apps.scm
@@ -15,6 +15,7 @@
;;; Copyright © 2019, 2020 Alex Griffin <a@ajgrf.com>
;;; Copyright © 2020 Alexandru-Sergiu Marton <brown121407@member.fsf.org>
;;; Copyright © 2020 Brian Leung <bkleung89@gmail.com>
+;;; Copyright © 2021 EuAndreh <eu@euandre.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -690,6 +691,35 @@ By operating at a lower level than most similar tools, it supports X11,
Wayland, and Linux console environments alike.")
(license license:expat)))
+(define-public nixfmt
+ (package
+ (name "ghc-nixfmt")
+ (version "0.4.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://hackage.haskell.org/package/nixfmt/nixfmt-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32 "1ispgl8rc2scr6v8bb6sks7px856jf61x74zj2iyddrn5qamkb3n"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-megaparsec" ,ghc-megaparsec)
+ ("ghc-parser-combinators" ,ghc-parser-combinators)
+ ("ghc-cmdargs" ,ghc-cmdargs)
+ ("ghc-safe-exceptions" ,ghc-safe-exceptions)))
+ (arguments
+ `(#:cabal-revision
+ ("1" "1hsj0jh6siph3afd9c2wii09sffl48rzqv653n4clpd8qy0rn48d")))
+ (home-page "https://github.com/serokell/nixfmt")
+ (synopsis "Opinionated formatter for Nix")
+ (description
+ "Nixfmt is a formatter for Nix that ensures consistent and clear
+formatting by forgetting all existing formatting during parsing.")
+ (license license:mpl2.0)))
+
(define-public raincat
(package
(name "raincat")
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index c4440d4778..d6c50ade71 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -28,7 +28,6 @@
;;; Copyright © 2020 Alexandru-Sergiu Marton <brown121407@member.fsf.org>
;;; Copyright © 2020 Carlo Holl <carloholl@gmail.com>
;;; Copyright © 2020 Christopher Lemmer Webber <cwebber@dustycloud.org>
-;;; Copyright © 2021 EuAndreh <eu@euandre.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -8694,35 +8693,6 @@ making this package a full replacement for the original newtype package,
and an alternative to newtype-th.")
(license license:bsd-3)))
-(define-public ghc-nixfmt
- (package
- (name "ghc-nixfmt")
- (version "0.4.0")
- (source
- (origin
- (method url-fetch)
- (uri (string-append
- "https://hackage.haskell.org/package/nixfmt/nixfmt-"
- version
- ".tar.gz"))
- (sha256
- (base32 "1ispgl8rc2scr6v8bb6sks7px856jf61x74zj2iyddrn5qamkb3n"))))
- (build-system haskell-build-system)
- (inputs
- `(("ghc-megaparsec" ,ghc-megaparsec)
- ("ghc-parser-combinators" ,ghc-parser-combinators)
- ("ghc-cmdargs" ,ghc-cmdargs)
- ("ghc-safe-exceptions" ,ghc-safe-exceptions)))
- (arguments
- `(#:cabal-revision
- ("1" "1hsj0jh6siph3afd9c2wii09sffl48rzqv653n4clpd8qy0rn48d")))
- (home-page "https://github.com/serokell/nixfmt")
- (synopsis "Opinionated formatter for Nix")
- (description
- "Nixfmt is a formatter for Nix that ensures consistent and clear
-formatting by forgetting all existing formatting during parsing.")
- (license license:mpl2.0)))
-
(define-public ghc-non-negative
(package
(name "ghc-non-negative")