aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2021-02-07 22:51:24 +0000
committerGuillaume Le Vaillant <glv@posteo.net>2021-02-19 11:05:33 +0100
commitac7d2eef807dfbd5e3279fd924f52a65ebe5d6f7 (patch)
tree226772a5a0c731e1cba58b15d2837fdbe96b2a48
parent9daa9f2a6f32ae01c1a4b65d866809d5318c04e8 (diff)
downloadguix-ac7d2eef807dfbd5e3279fd924f52a65ebe5d6f7.tar
guix-ac7d2eef807dfbd5e3279fd924f52a65ebe5d6f7.tar.gz
gnu: Add python-pytest-astropy.
* gnu/packages/python-check.scm (python-pytest-astropy): New variable. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
-rw-r--r--gnu/packages/python-check.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index c449a0fe43..15efdd3297 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -221,6 +221,41 @@ running pytest. It can be used with packages that are not affiliated with the
Astropy project, but is optimized for use with astropy-related projects.")
(license license:bsd-3)))
+(define-public python-pytest-astropy
+ (package
+ (name "python-pytest-astropy")
+ (version "0.8.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pytest-astropy" version))
+ (sha256
+ (base32 "18j6z6y2fvykmcs5z0mldhhaxxn6wzpnhlm2ps7m8r5z5kmh1631"))))
+ (build-system python-build-system)
+ (arguments
+ ;; No tests provided
+ '(#:tests? #f))
+ (native-inputs
+ `(("attrs" ,python-attrs)
+ ("hypothesis" ,python-hypothesis)
+ ("pytest" ,python-pytest)
+ ("pytest-arraydiff" ,python-pytest-arraydiff)
+ ("pytest-astropy-header" ,python-pytest-astropy-header)
+ ("pytest-cov" ,python-pytest-cov)
+ ("pytest-doctestplus" ,python-pytest-doctestplus)
+ ("pytest-filter-subpackage" ,python-pytest-filter-subpackage)
+ ("pytest-mock" ,python-pytest-mock)
+ ("pytest-openfiles" ,python-pytest-openfiles)
+ ("pytest-remotedata" ,python-pytest-remotedata)
+ ("setuptools-scm" ,python-setuptools-scm)))
+ (home-page "https://github.com/astropy/pytest-astropy")
+ (synopsis
+ "Metapackage for all the testing machinery used by the Astropy Project")
+ (description
+ "This is a meta-package that pulls in the dependencies that are used by
+astropy related packages.")
+ (license license:bsd-3)))
+
(define-public python-pytest-arraydiff
(package
(name "python-pytest-arraydiff")