aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2021-01-23 16:37:07 +0100
committerPierre Neidhardt <mail@ambrevar.xyz>2021-01-24 11:39:16 +0100
commitabf21b14814d555d3ffb6b8d6230295bf97c6642 (patch)
tree1c0c86cb0b2d80530a6279223fce31d1f591d908
parent4e0b0bf2f2e6076aa52447b303ac9033cec69f5f (diff)
downloadguix-abf21b14814d555d3ffb6b8d6230295bf97c6642.tar
guix-abf21b14814d555d3ffb6b8d6230295bf97c6642.tar.gz
gnu: Add system-locale.
* gnu/packages/lisp-xyz.scm (cl-system-locale, ecl-system-locale, sbcl-system-locale): New variables.
-rw-r--r--gnu/packages/lisp-xyz.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 10add7271c..a95a7d7b2d 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -13475,3 +13475,34 @@ objects themselves.")
(define-public cl-jsown
(sbcl-package->cl-source-package sbcl-jsown))
+
+(define-public sbcl-system-locale
+ (let ((commit "4b334bc2fa45651bcaa28ae7d9331095d6bf0a17"))
+ (package
+ (name "sbcl-system-locale")
+ (version (git-version "1.0.0" "1" commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Shinmera/system-locale/")
+ (commit commit)))
+ (file-name (git-file-name name commit))
+ (sha256
+ (base32 "00p5c053kmgq4ks6l9mxsqz6g3bjcybvkvj0bh3r90qgpkaawm1p"))))
+ (build-system asdf-build-system/sbcl)
+ (inputs
+ `(("documentation-utils" ,sbcl-documentation-utils)))
+ (home-page "https://shinmera.github.io/system-locale/")
+ (synopsis "Get the system's locale and language settings in Common Lisp")
+ (description
+ "This library retrieves locale information configured on the
+system. This is helpful if you want to write applications and libraries that
+display messages in the user's native language.")
+ (license license:zlib))))
+
+(define-public ecl-system-locale
+ (sbcl-package->ecl-package sbcl-system-locale))
+
+(define-public cl-system-locale
+ (sbcl-package->cl-source-package sbcl-system-locale))