aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Reichör <stefan@xsteve.at>2021-02-18 21:26:06 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-02-18 22:09:47 +0100
commita30f250d7426df48f5532cd339b8f53dd6e4dd3a (patch)
tree3e5829f9dd26a52634ad01601597344af508f1b7
parent5fccdbc079402eee345684bcbd1b1d0306cab1e8 (diff)
downloadguix-a30f250d7426df48f5532cd339b8f53dd6e4dd3a.tar
guix-a30f250d7426df48f5532cd339b8f53dd6e4dd3a.tar.gz
gnu: Add vitetris.
* gnu/packages/games.scm (vitetris): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/games.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index d8c98a9a2f..6726cef303 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -57,6 +57,7 @@
;;; Copyright © 2020 Lu hux <luhux@outlook.com>
;;; Copyright © 2020 Tomás Ortín Fernández <tomasortin@mailbox.org>
;;; Copyright © 2021 Olivier Rojon <o.rojon@posteo.net>
+;;; Copyright © 2021 Stefan Reichör <stefan@xsteve.at>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -545,6 +546,40 @@ Playing bastet can be a painful experience, especially if you usually make
canyons and wait for the long I-shaped block to clear four rows at a time.")
(license license:gpl3+)))
+(define-public vitetris
+ (package
+ (name "vitetris")
+ (version "0.59.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/vicgeralds/vitetris")
+ (commit (string-append "v" version))))
+ (sha256
+ (base32 "1ah1c5g7abksif0n8v5rb7r4pn2az20c3mkp4ak13vgs23ddmds5"))
+ (file-name (git-file-name name version))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ;no test
+ #:make-flags
+ (list ,(string-append "CC=" (cc-for-target))
+ (string-append "DESTDIR=" (assoc-ref %outputs "out")))
+ #:phases
+ (modify-phases %standard-phases
+ (replace 'configure
+ (lambda _
+ ;; the non standard configure script does not accept
+ ;; standard parameters -> invoke configure by hand
+ (invoke "./configure" "prefix=")
+ ;; src/src-conf.mk must be writable for the build step
+ (make-file-writable "src/src-conf.mk"))))))
+ (home-page "http://victornils.net/tetris/")
+ (synopsis "Terminal-based Tetris clone")
+ (description "Vitetris is a classic multiplayer Tetris clone for the
+terminal.")
+ (license license:bsd-2)))
+
(define-public blobwars
(package
(name "blobwars")