aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2021-02-07 22:42:03 +0000
committerGuillaume Le Vaillant <glv@posteo.net>2021-02-19 11:05:33 +0100
commit9daa9f2a6f32ae01c1a4b65d866809d5318c04e8 (patch)
treefc6c36b9d71cadc7db333dcdb8e04b9cd0aeb3d5
parentf90bbba4cc3b85e1fc0dec9efe87f323ea97caef (diff)
downloadguix-9daa9f2a6f32ae01c1a4b65d866809d5318c04e8.tar
guix-9daa9f2a6f32ae01c1a4b65d866809d5318c04e8.tar.gz
gnu: Add python-pytest-astropy-header.
* gnu/packages/python-check.scm (python-pytest-astropy-header): New variable. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
-rw-r--r--gnu/packages/python-check.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index c23741825b..c449a0fe43 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -9,6 +9,7 @@
;;; Copyright © 2020 Edouard Klein <edk@beaver-labs.com>
;;; Copyright © 2020 Vinicius Monego <monego@posteo.net>
;;; Copyright © 2020 Tanguy Le Carrour <tanguy@bioneland.org>
+;;; Copyright © 2021 Sharlatan Hellseher <sharlatanus@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -196,6 +197,30 @@ interactions, which will update them to correspond to the new API.")
of tests run in a specific order.")
(license license:expat)))
+(define-public python-pytest-astropy-header
+(package
+ (name "python-pytest-astropy-header")
+ (version "0.1.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pytest-astropy-header" version))
+ (sha256
+ (base32 "1y87agr324p6x5gvhziymxjlw54pyn4gqnd49papbl941djpkp5g"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("pytest" ,python-pytest)
+ ("setuptools-scm" ,python-setuptools-scm)))
+ (home-page "https://www.astropy.org/")
+ (synopsis
+ "Pytest plugin adding diagnostic data to the header of the test output")
+ (description
+ "This plugin package provides a way to include information about the system,
+Python installation, and select dependencies in the header of the output when
+running pytest. It can be used with packages that are not affiliated with the
+Astropy project, but is optimized for use with astropy-related projects.")
+ (license license:bsd-3)))
+
(define-public python-pytest-arraydiff
(package
(name "python-pytest-arraydiff")