aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-03-15 11:36:38 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-03-15 11:36:38 +0100
commit963dfd3a06a1a9906706ea6bad34f89cc617d905 (patch)
treeb47b7b21bf1ba383c68055d05ee859fc939ca4c6
parente4a17532f9f99542e83ffdb79d205d6955f6e98e (diff)
downloadguix-963dfd3a06a1a9906706ea6bad34f89cc617d905.tar
guix-963dfd3a06a1a9906706ea6bad34f89cc617d905.tar.gz
gnu: Add python-toolshed.
* gnu/packages/python-xyz.scm (python-toolshed): New variable.
-rw-r--r--gnu/packages/python-xyz.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 706524bbb6..fa2701bc1c 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -15125,3 +15125,23 @@ and dates in \"human readable\" forms. For example, it would display
(description "Txaio provides a compatibility layer between the Python
@code{asyncio} module and @code{Twisted}.")
(license license:expat)))
+
+(define-public python-toolshed
+ (package
+ (name "python-toolshed")
+ (version "0.4.6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "toolshed" version))
+ (sha256
+ (base32
+ "14zvz51gzf9i1i3d1sj363ba4rksl6lcf4lz1arl8hpqgcbir8r3"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-nose" ,python-nose)))
+ (home-page "https://github.com/brentp/toolshed/")
+ (synopsis "Collection of modules and functions for working with data")
+ (description "This is a collection of well-tested, simple modules and
+functions that aim to reduce boilerplate when working with data.")
+ (license license:bsd-2)))