aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-09-01 16:23:37 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-09-04 21:45:44 -0400
commit8b41fdaf3f81271a76e7cb6182253a4cd04f3801 (patch)
treec66be19c393fa0c7d29f47699424a48d5207005b
parent49bf16b6b1d3834b98f07e3dc0a2ba3b974feb20 (diff)
downloadguix-8b41fdaf3f81271a76e7cb6182253a4cd04f3801.tar
guix-8b41fdaf3f81271a76e7cb6182253a4cd04f3801.tar.gz
gnu: make-linux-libre-source: Set output port buffering to line mode.
* gnu/packages/linux.scm (make-linux-libre-source): Set output port buffering to line mode via setvbuf. Remove the ad-hoc calls to force-output.
-rw-r--r--gnu/packages/linux.scm7
1 files changed, 3 insertions, 4 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 499f5bb220..b4909d4045 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -279,6 +279,9 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
(srfi srfi-1)
(ice-9 match)
(ice-9 ftw))
+
+ (setvbuf (current-output-port) 'line)
+
(let ((dir (string-append "linux-" #$version)))
(mkdir "/tmp/bin")
@@ -315,12 +318,10 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
(if (file-is-directory? #+upstream-source)
(begin
(format #t "Copying upstream linux source...~%")
- (force-output)
(invoke "cp" "--archive" #+upstream-source dir)
(invoke "chmod" "--recursive" "u+w" dir))
(begin
(format #t "Unpacking upstream linux tarball...~%")
- (force-output)
(invoke "tar" "xf" #$upstream-source)
(match (scandir "."
(lambda (name)
@@ -334,11 +335,9 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
(with-directory-excursion dir
(format #t "Running deblob script...~%")
- (force-output)
(invoke "/tmp/bin/deblob"))
(format #t "~%Packing new Linux-libre tarball...~%")
- (force-output)
(invoke "tar" "cvfa" #$output
;; Avoid non-determinism in the archive.
"--mtime=@0"