aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2021-02-16 22:44:03 +0000
committerGuillaume Le Vaillant <glv@posteo.net>2021-02-19 11:05:34 +0100
commit87530f7b4d4ec26a648e71df0592dbf9987417e3 (patch)
tree6e037e6f234dbcb10889b8d5b06ce736a1fa82fa
parentd6996fa05277f240b70b18c227419c371cfc737f (diff)
downloadguix-87530f7b4d4ec26a648e71df0592dbf9987417e3.tar
guix-87530f7b4d4ec26a648e71df0592dbf9987417e3.tar.gz
gnu: Add libskry.
* gnu/packages/astronomy.scm (libskry): New variable. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
-rw-r--r--gnu/packages/astronomy.scm43
1 files changed, 43 insertions, 0 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index b10b8013cb..5e5a9a2634 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -54,6 +54,7 @@
#:use-module (gnu packages python-xyz)
#:use-module (gnu packages qt)
#:use-module (gnu packages version-control)
+ #:use-module (gnu packages video)
#:use-module (gnu packages xiph)
#:use-module (gnu packages xorg)
#:use-module (guix build-system cmake)
@@ -514,6 +515,48 @@ Mechanics, Astrometry and Astrodynamics library.")
(license (list license:lgpl2.0+
license:gpl2+)))) ; examples/transforms.c & lntest/*.c
+(define-public libskry
+ (package
+ (name "libskry")
+ (version "0.3.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/GreatAttractor/libskry")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "14kwng0j8wqzlb0gqg3ayq36l15dpz7kvxc56fa47j55b376bwh6"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:make-flags
+ (list
+ (string-append
+ "LIBAV_INCLUDE_PATH=" (assoc-ref %build-inputs "ffmpeg") "/include"))
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure) ;; no configure provided
+ (delete 'check) ;; no tests provided
+ (replace 'install
+ ;; The Makefile lacks an ‘install’ target.
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (lib (string-append out "/lib"))
+ (include (string-append out "/include")))
+ (copy-recursively "bin" lib)
+ (copy-recursively "include" include))
+ #t)))))
+ (inputs
+ `(("ffmpeg" ,ffmpeg)))
+ (home-page "https://github.com/GreatAttractor/libskry")
+ (synopsis "Astronimical lucky imaging library")
+ (description
+ "@code{libskry} implements the lucky imaging principle of astronomical
+imaging: creating a high-quality still image out of a series of many thousands)
+low quality ones")
+ (license license:gpl3+)))
+
(define-public libpasastro
;; NOTE: (Sharlatan-20210122T215921+0000): the version tag has a build
;; error on spice which is resolved with the latest commit.