aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2021-01-21 19:47:28 +0100
committerPierre Neidhardt <mail@ambrevar.xyz>2021-01-21 19:47:28 +0100
commit833d220d0b22c44793ea42c8e0e4296456c45b43 (patch)
treed54a47fa6e7a05b87088e562dd6ad14dc32c9b45
parent4fce867ddfafb5a7a5ec1835dc791006b3c9d269 (diff)
downloadguix-833d220d0b22c44793ea42c8e0e4296456c45b43.tar
guix-833d220d0b22c44793ea42c8e0e4296456c45b43.tar.gz
gnu: Add ppath.
* gnu/packages/lisp-xyz.scm (cl-ppath, ecl-ppath, sbcl-ppath): New variables.
-rw-r--r--gnu/packages/lisp-xyz.scm43
1 files changed, 43 insertions, 0 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 8f0321fa11..1c98c032c8 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -13233,3 +13233,46 @@ be usable from multi-threaded programs.")
(define-public cl-cmd
(sbcl-package->ecl-package sbcl-cmd))
+
+(define-public sbcl-ppath
+ (let ((commit "eb1a8173b4d1d691ea9a7699412123462f58c3ce"))
+ (package
+ (name "sbcl-ppath")
+ (version (git-version "0.1" "1" commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/fourier/ppath/")
+ (commit commit)))
+ (file-name (git-file-name name commit))
+ (sha256
+ (base32 "1c46q9lmzqv14z80d3fwdawgn3pn4922x31fyqvsvbcjm4hd16fb"))))
+ (build-system asdf-build-system/sbcl)
+ (inputs
+ `(("alexandria" ,sbcl-alexandria)
+ ("cffi" ,sbcl-cffi)
+ ("osicat" ,sbcl-osicat)
+ ("ppcre" ,sbcl-cl-ppcre)
+ ("split-sequence" ,sbcl-split-sequence)
+ ("trivial-features" ,sbcl-trivial-features)))
+ (native-inputs
+ `(("cl-fad" ,sbcl-cl-fad)
+ ("prove" ,sbcl-prove)))
+ (home-page "https://github.com/fourier/ppath")
+ (synopsis "Common Lisp's implementation of the Python's os.path module")
+ (description
+ "This library is a path strings manipulation library inspired by
+Python's @code{os.path}. All functionality from @code{os.path} is supported on
+major operation systems.
+
+The philosophy behind is to use simple strings and \"dumb\" string
+manipulation functions to handle paths and filenames. Where possible the
+corresponding OS system functions are called.")
+ (license license:bsd-2))))
+
+(define-public ecl-ppath
+ (sbcl-package->ecl-package sbcl-ppath))
+
+(define-public cl-ppath
+ (sbcl-package->ecl-package sbcl-ppath))