aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2017-06-18 14:00:23 +0200
committerDanny Milosavljevic <dannym@scratchpost.org>2017-06-18 14:10:26 +0200
commit7fadeab448b602987765184685e329a59b615c64 (patch)
treed710b51959040187a8c9d98a633d19f702efb59e
parent61253c4f9759fa83c20d9e09d58a7e7c6dd06572 (diff)
downloadguix-7fadeab448b602987765184685e329a59b615c64.tar
guix-7fadeab448b602987765184685e329a59b615c64.tar.gz
gnu: Add python-smmap2.
* gnu/packages/python.scm (python-smmap2, python2-smmap2): New variables.
-rw-r--r--gnu/packages/python.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 92413aa458..c07bbae3e9 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -15383,3 +15383,26 @@ many of the popular cloud service providers using a unified API.")
(define-public python2-apache-libcloud
(package-with-python2 python-apache-libcloud))
+
+(define-public python-smmap2
+ (package
+ (name "python-smmap2")
+ (version "2.0.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "smmap2" version))
+ (sha256
+ (base32
+ "1hvn28p3zvxa98sbi9lrqvv2ps4q284j4jq9a619zw0m7yv0sly7"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-nosexcover" ,python-nosexcover)))
+ (home-page "https://github.com/Byron/smmap")
+ (synopsis "Python sliding window memory map manager")
+ (description "@code{smmap2} is a pure Python implementation of a sliding
+window memory map manager.")
+ (license license:bsd-3)))
+
+(define-public python2-smmap2
+ (package-with-python2 python-smmap2))