aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGreg Hogan <code@greghogan.com>2021-02-11 19:08:35 +0000
committerLeo Famulari <leo@famulari.name>2021-02-18 13:03:48 -0500
commit7cd0247eb4d22d47f76e26fd7b65ec45cb5d7ccb (patch)
tree61ecfe4c5114120958d1bb66816de5afb41c61cb
parentac19e83b52673b21a11f95cb5369a1da84576da3 (diff)
downloadguix-7cd0247eb4d22d47f76e26fd7b65ec45cb5d7ccb.tar
guix-7cd0247eb4d22d47f76e26fd7b65ec45cb5d7ccb.tar.gz
gnu: gperftools: Update to 2.8.1.
* gnu/packages/cpp.scm (gperftools): Update to 2.8.1. [arguments]: Set '#:parallel-tests? #f'. Co-authored-by: Leo Famulari <leo@famulari.name>
-rw-r--r--gnu/packages/cpp.scm8
1 files changed, 6 insertions, 2 deletions
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index ae47490755..331afc2e3e 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -512,7 +512,7 @@ maintained anymore.")
(define-public gperftools
(package
(name "gperftools")
- (version "2.8")
+ (version "2.8.1")
(source
(origin
(method git-fetch)
@@ -520,9 +520,13 @@ maintained anymore.")
(url "https://github.com/gperftools/gperftools")
(commit (string-append "gperftools-" version))))
(sha256
- (base32 "1rnc53kaxlljgbpsff906vdsry9jl9gcvcnmxgkprwzxq1wipyd0"))
+ (base32 "19bj2vlsbfwq7m826v2ccqg47kd7cb5vcz1yw2x0v5qzhaxbakk1"))
(file-name (git-file-name name version))))
(build-system gnu-build-system)
+ (arguments
+ ;; The tests are flaky when run in parallel. For more info:
+ ;; https://bugs.gnu.org/46562
+ '(#:parallel-tests? #f))
(native-inputs
`(("autoconf" ,autoconf)
("automake" ,automake)