aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2021-02-07 23:29:45 +0000
committerGuillaume Le Vaillant <glv@posteo.net>2021-02-19 11:05:33 +0100
commit74acb300a34cc19a10e72d7d7f67635ef59b8eb7 (patch)
tree74e855ca0546ea664e7bce77f02ebb71d28b577a
parentac7d2eef807dfbd5e3279fd924f52a65ebe5d6f7 (diff)
downloadguix-74acb300a34cc19a10e72d7d7f67635ef59b8eb7.tar
guix-74acb300a34cc19a10e72d7d7f67635ef59b8eb7.tar.gz
gnu: Add python-extension-helpers.
* gnu/packages/python-xyz.scm (python-extension-helpers): New variable. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
-rw-r--r--gnu/packages/python-xyz.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index a504bb521b..dbb79e608c 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -96,6 +96,7 @@
;;; Copyright © 2020, 2021 Zheng Junjie <873216071@qq.com>
;;; Copyright © 2021 Morgan Smith <Morgan.J.Smith@outlook.com>
;;; Copyright © 2020 EuAndreh <eu@euandre.org>
+;;; Copyright © 2021 Sharlatan Hellseher <sharlatanus@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -2382,6 +2383,30 @@ software.")
(inherit (package-with-python2 scons))
(name "scons-python2")))
+(define-public python-extension-helpers
+(package
+ (name "python-extension-helpers")
+ (version "0.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "extension-helpers" version))
+ (sha256
+ (base32 "10iqjzmya2h4sk765dlm1pbqypwlqyh8rw59a5m9i63d3klnz2mc"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("coverage" ,python-coverage)
+ ("pytest" ,python-pytest-astropy)
+ ("pytest-cov" ,python-pytest-cov)
+ ("setuptools-scm" ,python-setuptools-scm)))
+ (home-page "https://github.com/astropy/astropy-helpers")
+ (synopsis
+ "Utilities for building and installing packages in the Astropy ecosystem")
+ (description
+ "The extension-helpers package includes many build, installation, and
+documentation-related tools used by the Astropy project.")
+ (license license:bsd-3)))
+
(define-public python-extras
(package
(name "python-extras")