aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEuAndreh via Guix-patches via <guix-patches@gnu.org>2021-02-08 22:14:52 -0300
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-02-21 01:48:53 +0100
commit703ccd583611b6efa689b7a2d1daf35d6cd83c35 (patch)
tree6528a4c2a3b887ec5e022c47e5ff69c3db51e9e9
parentc7be46b7d754cbf0d0526b5d8a9d1ecee64b6154 (diff)
downloadguix-703ccd583611b6efa689b7a2d1daf35d6cd83c35.tar
guix-703ccd583611b6efa689b7a2d1daf35d6cd83c35.tar.gz
gnu: Add ghc-nixfmt.
* gnu/packages/haskell-xyz.scm (ghc-nixfmt): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/haskell-xyz.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index d6c50ade71..c4440d4778 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -28,6 +28,7 @@
;;; Copyright © 2020 Alexandru-Sergiu Marton <brown121407@member.fsf.org>
;;; Copyright © 2020 Carlo Holl <carloholl@gmail.com>
;;; Copyright © 2020 Christopher Lemmer Webber <cwebber@dustycloud.org>
+;;; Copyright © 2021 EuAndreh <eu@euandre.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -8693,6 +8694,35 @@ making this package a full replacement for the original newtype package,
and an alternative to newtype-th.")
(license license:bsd-3)))
+(define-public ghc-nixfmt
+ (package
+ (name "ghc-nixfmt")
+ (version "0.4.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://hackage.haskell.org/package/nixfmt/nixfmt-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32 "1ispgl8rc2scr6v8bb6sks7px856jf61x74zj2iyddrn5qamkb3n"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-megaparsec" ,ghc-megaparsec)
+ ("ghc-parser-combinators" ,ghc-parser-combinators)
+ ("ghc-cmdargs" ,ghc-cmdargs)
+ ("ghc-safe-exceptions" ,ghc-safe-exceptions)))
+ (arguments
+ `(#:cabal-revision
+ ("1" "1hsj0jh6siph3afd9c2wii09sffl48rzqv653n4clpd8qy0rn48d")))
+ (home-page "https://github.com/serokell/nixfmt")
+ (synopsis "Opinionated formatter for Nix")
+ (description
+ "Nixfmt is a formatter for Nix that ensures consistent and clear
+formatting by forgetting all existing formatting during parsing.")
+ (license license:mpl2.0)))
+
(define-public ghc-non-negative
(package
(name "ghc-non-negative")