aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArun Isaac <arunisaac@systemreboot.net>2017-03-19 00:22:51 +0530
committerMarius Bakke <mbakke@fastmail.com>2017-03-20 00:40:30 +0100
commit6ba0af7960149455d9c692e8b29eddbd517ab758 (patch)
tree569dd0aff770ed5acd1dbd5b00eb914afb788299
parentd5ef113c055a537cec06bc86244b98c4ebb3b925 (diff)
downloadguix-6ba0af7960149455d9c692e8b29eddbd517ab758.tar
guix-6ba0af7960149455d9c692e8b29eddbd517ab758.tar.gz
gnu: Add python-isort.
* gnu/packages/python.scm (python-isort, python2-isort): New variables. Signed-off-by: Marius Bakke <mbakke@fastmail.com>
-rw-r--r--gnu/packages/python.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index cf06212b6c..a8cec0de9a 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -13722,3 +13722,32 @@ builds partial trees by inspecting living objects.")
(define-public python2-astroid
(package-with-python2 python-astroid))
+
+(define-public python-isort
+ (package
+ (name "python-isort")
+ (version "4.2.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/timothycrosley/isort/archive/"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0zsrgkb0krn5476yncy5dd56k7dk34zqb4bnlvwy44ixgilyjmfh"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-mock" ,python-mock)
+ ("python-pytest" ,python-pytest)))
+ (home-page "https://github.com/timothycrosley/isort")
+ (synopsis "Python utility/library to sort python imports")
+ (description "@code{python-isort} is a python utility/library to sort
+imports alphabetically, and automatically separated into sections. It
+provides a command line utility, a python library and plugins for various
+editors.")
+ (license license:expat)))
+
+(define-public python2-isort
+ (package-with-python2 python-isort))