aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2021-02-19 23:53:54 -0300
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-02-21 01:13:52 +0100
commit659c2c5232df23d3a87b08dfa7cd272ae7fceb1b (patch)
tree88bef61d4a0fd15e82f6f30222d3968f68c18f15
parent081d927409f0adc2ef32bdca055926a5b33cde2d (diff)
downloadguix-659c2c5232df23d3a87b08dfa7cd272ae7fceb1b.tar
guix-659c2c5232df23d3a87b08dfa7cd272ae7fceb1b.tar.gz
gnu: Add imgp.
* gnu/packages/image.scm (imgp): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/image.scm35
1 files changed, 34 insertions, 1 deletions
diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index 28169b0295..68221afff1 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -27,7 +27,7 @@
;;; Copyright © 2020 R Veera Kumar <vkor@vkten.in>
;;; Copyright © 2020 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2020 Zhu Zihao <all_but_last@163.com>
-;;; Copyright © 2020 Vinicius Monego <monego@posteo.net>
+;;; Copyright © 2020, 2021 Vinicius Monego <monego@posteo.net>
;;; Copyright © 2021 Sharlatan Hellseher <sharlatanus@gmail.com>
;;;
;;; This file is part of GNU Guix.
@@ -1581,6 +1581,39 @@ PNG, and performs PNG integrity checks and corrections.")
(home-page "http://optipng.sourceforge.net/")
(license license:zlib)))
+(define-public imgp
+ (package
+ (name "imgp")
+ (version "2.8")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "imgp" version))
+ (sha256
+ (base32 "0q99h9wv9rynig0s0flnr9mxi541zzl0gw8vh4y6m5x132diilri"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:tests? #f ;there are no tests
+ #:phases
+ (modify-phases %standard-phases
+ ;; setup.py expects the file to be named 'imgp'.
+ (add-after 'unpack 'rename-imgp
+ (lambda _
+ (rename-file "imgp.py" "imgp")
+ #t)))))
+ (inputs
+ `(("python-pillow" ,python-pillow)))
+ (home-page "https://github.com/jarun/imgp")
+ (synopsis "High-performance CLI batch image resizer & rotator")
+ (description
+ "@code{imgp} is a command line image resizer and rotator for JPEG and PNG
+images. It can resize (or thumbnail) and rotate thousands of images in a go
+while saving significantly on storage.
+
+This package may optionally be built with @code{python-pillow-simd} in place
+of @{python-pillow} for SIMD parallelism.")
+ (license license:gpl3+)))
+
(define-public pngsuite
(package
(name "pngsuite")