aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArun Isaac <arunisaac@systemreboot.net>2017-03-19 00:22:54 +0530
committerMarius Bakke <mbakke@fastmail.com>2017-03-20 00:40:31 +0100
commit61550dedf3fd16d6174c48243439b232b9a4ef4f (patch)
tree031bddfaae8e9aea8acc2687bd6e93a826f0b2fc
parent23db3fc67d210ed121d6f5c8eeeffcc695dbd67d (diff)
downloadguix-61550dedf3fd16d6174c48243439b232b9a4ef4f.tar
guix-61550dedf3fd16d6174c48243439b232b9a4ef4f.tar.gz
gnu: Add python2-coverage-test-runner.
* gnu/packages/python.scm (python2-coverage-test-runner): New variable. Signed-off-by: Marius Bakke <mbakke@fastmail.com>
-rw-r--r--gnu/packages/python.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index eb2c65f205..2250061de3 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -13799,3 +13799,34 @@ in other versions.")
(define-public python2-configparser
(package-with-python2 python-configparser))
+
+(define-public python2-coverage-test-runner
+ (package
+ (name "python2-coverage-test-runner")
+ (version "1.11")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://git.liw.fi/cgi-bin/cgit/cgit.cgi/"
+ "coverage-test-runner/snapshot/coverage-test-runner-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0y1m7z3dl63kmhcmydl1mwg0hacnf6ghrx9dah17j9iasssfa3g7"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:python ,python-2
+ #:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda _
+ (zero? (system* "./testrun")))))))
+ (propagated-inputs
+ `(("python2-coverage" ,python2-coverage)))
+ (home-page "https://liw.fi/coverage-test-runner/")
+ (synopsis "Python module for running unit tests")
+ (description "@code{CoverageTestRunner} is a python module for running
+unit tests and failing them if the unit test module does not excercise all
+statements in the module it tests.")
+ (license license:gpl3+)))