aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-02-18 13:26:59 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-02-18 15:37:34 -0500
commit5fccdbc079402eee345684bcbd1b1d0306cab1e8 (patch)
treeaaa158508e4ab2624c56ff9bde4e0e19dbf1906e
parent13de68587730aa812926256b3269ada315944b99 (diff)
downloadguix-5fccdbc079402eee345684bcbd1b1d0306cab1e8.tar
guix-5fccdbc079402eee345684bcbd1b1d0306cab1e8.tar.gz
gnu: emacs-elpy: Fix build.
Fixes <https://issues.guix.gnu.org/46516>, which was caused by commit 41abf3b3a0fabe06817f3940cba778974ce79c46. * gnu/packages/emacs-xyz.scm (emacs-elpy)[phases] {patch-ffip-project-search-call}: New phase. Reported-by: Simon Streit <simon@netpanic.org> and others.
-rw-r--r--gnu/packages/emacs-xyz.scm9
1 files changed, 9 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 4344520430..3c3dad73f2 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -9166,6 +9166,15 @@ indentation guides in Emacs:
`(#:include (cons* "^elpy/[^/]+\\.py$" "^snippets\\/" %default-include)
#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'patch-ffip-project-search-call
+ (lambda _
+ ;; Since version 6.0.0 of find-file-in-project,
+ ;; ffip-project-search doesn't accept a third argument anymore
+ ;; (see: https://github.com/jorgenschaefer/elpy/issues/1889).
+ (substitute* "elpy.el"
+ (("\\((ffip-project-search nil nil) project-root\\)" _ signature)
+ (format #f "(let ((ffip-project-root project-root)) (~a))"
+ signature)))))
;; The default environment of the RPC uses Virtualenv to install
;; Python dependencies from PyPI. We don't want/need this in Guix.
(add-before 'check 'do-not-use-virtualenv