aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-02-18 23:06:42 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-02-19 10:01:01 -0500
commit5363d3751b272f5433c993d9944f9466455f6aa8 (patch)
treea80db2030f6633e1d60d5619009cf1ae05ee25b9
parentc2baa33e4b5963ca3343b0d180e2566611ccd23e (diff)
downloadguix-5363d3751b272f5433c993d9944f9466455f6aa8.tar
guix-5363d3751b272f5433c993d9944f9466455f6aa8.tar.gz
gnu: python-geventhttpclient: Adjust to build with updated gevent.
* gnu/packages/python-web.scm (python-geventhttpclient): Delete trailing #t. [phases]{fix-compatibility-issue}: New phase. {check}: Adjust comment and remove the extraneous string-append.
-rw-r--r--gnu/packages/python-web.scm19
1 files changed, 11 insertions, 8 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index ab3769b360..3cc20b2187 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -26,7 +26,7 @@
;;; Copyright © 2018 Tomáš Čech <sleep_walker@gnu.org>
;;; Copyright © 2018, 2019 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2018 Mathieu Othacehe <m.othacehe@gmail.com>
-;;; Copyright © 2018, 2020 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2018, 2020, 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2019 Vagrant Cascadian <vagrant@debian.org>
;;; Copyright © 2019 Brendan Tildesley <mail@brendan.scot>
;;; Copyright © 2019 Pierre Langlois <pierre.langlois@gmx.com>
@@ -3032,16 +3032,20 @@ for the basic TCP/IP protocols.")
'(begin
;; Delete pre-compiled files.
(for-each delete-file (find-files "src/geventhttpclient"
- ".*\\.pyc"))
- #t))))
+ ".*\\.pyc"))))))
(build-system python-build-system)
(arguments
'(#:phases
(modify-phases %standard-phases
(add-after 'unpack 'delete-network-tests
(lambda _
- (delete-file "src/geventhttpclient/tests/test_client.py")
- #t))
+ (delete-file "src/geventhttpclient/tests/test_client.py")))
+ (add-after 'unpack 'fix-compatibility-issue
+ ;; See: https://github.com/gwik/geventhttpclient/issues/137.
+ (lambda _
+ (substitute* "src/geventhttpclient/tests/test_ssl.py"
+ ((".*sock.last_seen_sni = None.*")
+ ""))))
(replace 'check
(lambda* (#:key inputs outputs #:allow-other-keys)
(add-installed-pythonpath inputs outputs)
@@ -3049,10 +3053,9 @@ for the basic TCP/IP protocols.")
;; Append the test modules to sys.path to avoid
;; namespace conflict which breaks SSL tests.
"--import-mode=append"
- ;; XXX: Disable test fails with Python 3.8:
+ ;; XXX: This test fails with Python 3.8:
;; https://github.com/gwik/geventhttpclient/issues/119
- "-k" (string-append "not test_cookielib_compatibility"))
- #t)))))
+ "-k" "not test_cookielib_compatibility"))))))
(native-inputs
`(("python-dpkt" ,python-dpkt)
("python-pytest" ,python-pytest)))