aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2021-02-21 21:15:05 +0100
committerMarius Bakke <marius@gnu.org>2021-02-21 21:39:38 +0100
commit4ac9db0d75edcacb3a0c98659620cfea3c1e1993 (patch)
treec54b6891cbf616630dda52daf2a35e2386ff9459
parent182d2ef5105c065832decfdbacf2dc568a92c874 (diff)
downloadguix-4ac9db0d75edcacb3a0c98659620cfea3c1e1993.tar
guix-4ac9db0d75edcacb3a0c98659620cfea3c1e1993.tar.gz
image: Add rock64 support.
* gnu/system/images/rock64.scm: New file. * gnu/local.mk (GNU_SYSTEM_MODULES): Adjust accordingly.
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/system/images/rock64.scm64
2 files changed, 65 insertions, 0 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 95d5835fa4..b8bccc1b7c 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -664,6 +664,7 @@ GNU_SYSTEM_MODULES = \
%D%/system/images/novena.scm \
%D%/system/images/pine64.scm \
%D%/system/images/pinebook-pro.scm \
+ %D%/system/images/rock64.scm \
\
%D%/machine.scm \
\
diff --git a/gnu/system/images/rock64.scm b/gnu/system/images/rock64.scm
new file mode 100644
index 0000000000..3f193e8528
--- /dev/null
+++ b/gnu/system/images/rock64.scm
@@ -0,0 +1,64 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2021 Marius Bakke <marius@gnu.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu system images rock64)
+ #:use-module (gnu bootloader)
+ #:use-module (gnu bootloader u-boot)
+ #:use-module (gnu image)
+ #:use-module (gnu packages linux)
+ #:use-module (gnu services)
+ #:use-module (gnu services base)
+ #:use-module (gnu services networking)
+ #:use-module (gnu system)
+ #:use-module (gnu system file-systems)
+ #:use-module (gnu system image)
+ #:use-module (srfi srfi-26)
+ #:export (rock64-barebones-os
+ rock64-image-type
+ rock64-barebones-raw-image))
+
+(define rock64-barebones-os
+ (operating-system
+ (host-name "jiehkkevarri")
+ (timezone "Europe/Oslo")
+ (locale "en_US.utf8")
+ (bootloader (bootloader-configuration
+ (bootloader u-boot-rock64-rk3328-bootloader)
+ (target "/dev/sda")))
+ (initrd-modules '())
+ (kernel linux-libre-arm64-generic)
+ (file-systems (cons (file-system
+ (device (file-system-label "my-root"))
+ (mount-point "/")
+ (type "ext4"))
+ %base-file-systems))
+ (services (append (list (service dhcp-client-service-type))
+ %base-services))))
+
+(define rock64-image-type
+ (image-type
+ (name 'rock64-raw)
+ (constructor (cut image-with-os (arm64-disk-image (expt 2 24)) <>))))
+
+(define rock64-barebones-raw-image
+ (image
+ (inherit
+ (os->image rock64-barebones-os #:type rock64-image-type))
+ (name 'rock64-barebones-raw-image)))
+
+rock64-barebones-raw-image