aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2021-02-16 14:08:27 -0500
committerLeo Famulari <leo@famulari.name>2021-02-19 15:45:18 -0500
commit319470bb3b75d619fd14ba16a8cf619342526000 (patch)
treed20f9e594d5b736a21653361bc0adc42ee4ae2cf
parente9bf51108272977d61a34e1af753f5064f0d57c7 (diff)
downloadguix-319470bb3b75d619fd14ba16a8cf619342526000.tar
guix-319470bb3b75d619fd14ba16a8cf619342526000.tar.gz
gnu: Add GtkDatabox.
* gnu/packages/gtk.scm (gtkdatabox): New variable.
-rw-r--r--gnu/packages/gtk.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index c6b4b6197a..34876ddd8f 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -25,6 +25,7 @@
;;; Copyright © 2020 Brendan Tildesley <mail@brendan.scot>
;;; Copyright © 2020 Guillaume Le Vaillant <glv@posteo.net>
;;; Copyright © 2020 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2021 Leo Famulari <leo@famulari.name>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -2266,3 +2267,27 @@ foreground and background colors, text justification and more.")
(variable "GLADE_MODULE_SEARCH_PATH")
(files '("lib/glade/modules")))))
(license license:lgpl2.0+)))
+
+(define-public gtkdatabox
+ (package
+ (name "gtkdatabox")
+ (version "0.9.3.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/gtkdatabox/gtkdatabox/"
+ version "/gtkdatabox-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1rdxnjgh6v3yjqgsfmamyzpfxckzchps4kqvvz88nifmd7ckhjfh"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("gtk+-2" ,gtk+-2)))
+ (synopsis "Display widget for dynamic data")
+ (description "GtkDatabox is a widget for live display of large amounts of
+fluctuating numerical data. It enables data presentation (for example, on
+linear or logarithmic scales, as dots or lines, with markers/labels) as well as
+user interaction (e.g. measuring distances).")
+ (home-page "https://sourceforge.net/projects/gtkdatabox/")
+ (license license:lgpl2.1+)))