aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-01-04 22:10:49 +0100
committerLudovic Courtès <ludo@gnu.org>2021-01-04 23:54:16 +0100
commit10612d61540228d48c998ba5b56f50da22534157 (patch)
tree7ac40f6a244fbd9e95bcbb94330b5d8c6d22965c
parentfa42774742fb1ddcb9f9424d8150d26f4033d426 (diff)
downloadguix-10612d61540228d48c998ba5b56f50da22534157.tar
guix-10612d61540228d48c998ba5b56f50da22534157.tar.gz
graph: Install JavaScript files.
Until now, 'guix graph --backend=d3js' wouldn't work outside the build tree. * d3.v3.js: Move to... * guix/d3.v3.js: ... here. * graph.js: Move to... * guix/graph.js: ... here. * Makefile.am (nobase_dist_guilemodule_DATA): Add them. (EXTRA_DIST): Remove them. * guix/graph.scm (emit-d3js-prologue, emit-d3js-epilogue): Adjust 'search-path' argument accordingly. * guix/self.scm (compiled-guix)[*extra-modules*]: Pass them via #:extra-files.
-rw-r--r--Makefile.am6
-rw-r--r--guix/d3.v3.js (renamed from d3.v3.js)0
-rw-r--r--guix/graph.js (renamed from graph.js)0
-rw-r--r--guix/graph.scm6
-rw-r--r--guix/self.scm7
5 files changed, 12 insertions, 7 deletions
diff --git a/Makefile.am b/Makefile.am
index aec2bb1474..51ff9c9ec9 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,5 +1,5 @@
# GNU Guix --- Functional package management for GNU
-# Copyright © 2012, 2013, 2014, 2015, 2016, 2017, 2018, 2019, 2020 Ludovic Courtès <ludo@gnu.org>
+# Copyright © 2012, 2013, 2014, 2015, 2016, 2017, 2018, 2019, 2020, 2021 Ludovic Courtès <ludo@gnu.org>
# Copyright © 2013 Andreas Enge <andreas@enge.fr>
# Copyright © 2015, 2017 Alex Kost <alezost@gmail.com>
# Copyright © 2016, 2018 Mathieu Lirzin <mthl@gnu.org>
@@ -397,6 +397,8 @@ EXAMPLES = \
GOBJECTS = $(MODULES:%.scm=%.go) guix/config.go $(dist_noinst_DATA:%.scm=%.go)
nobase_dist_guilemodule_DATA = \
+ guix/d3.v3.js \
+ guix/graph.js \
guix/store/schema.sql \
$(MODULES) $(MODULES_NOT_COMPILED) $(AUX_FILES) $(EXAMPLES) \
$(MISC_DISTRO_FILES)
@@ -611,8 +613,6 @@ EXTRA_DIST += \
build-aux/test-driver.scm \
build-aux/update-guix-package.scm \
build-aux/update-NEWS.scm \
- d3.v3.js \
- graph.js \
tests/test.drv \
tests/signing-key.pub \
tests/signing-key.sec \
diff --git a/d3.v3.js b/guix/d3.v3.js
index d234c4ec86..d234c4ec86 100644
--- a/d3.v3.js
+++ b/guix/d3.v3.js
diff --git a/graph.js b/guix/graph.js
index ad8279395d..ad8279395d 100644
--- a/graph.js
+++ b/guix/graph.js
diff --git a/guix/graph.scm b/guix/graph.scm
index 93ff9ef81a..0d4cd83667 100644
--- a/guix/graph.scm
+++ b/guix/graph.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2015, 2016, 2020 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2015, 2016, 2020, 2021 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2016 Ricardo Wurmus <rekado@elephly.net>
;;;
;;; This file is part of GNU Guix.
@@ -274,11 +274,11 @@ text {
var nodes = {},
nodeArray = [],
links = [];
-" (search-path %load-path "d3.v3.js")))
+" (search-path %load-path "guix/d3.v3.js")))
(define (emit-d3js-epilogue port)
(format port "</script><script type=\"text/javascript\" src=\"~a\"></script></body></html>"
- (search-path %load-path "graph.js")))
+ (search-path %load-path "guix/graph.js")))
(define (emit-d3js-node id label port)
(format port "\
diff --git a/guix/self.scm b/guix/self.scm
index 7cda6656c9..e2e3198057 100644
--- a/guix/self.scm
+++ b/guix/self.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2017, 2018, 2019, 2020 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2017, 2018, 2019, 2020, 2021 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2020 Martin Becze <mjbecze@riseup.net>
;;;
;;; This file is part of GNU Guix.
@@ -880,6 +880,11 @@ itself."
(name name))
(scheme-modules* source "guix"))
(list *core-modules*)
+
+ #:extra-files
+ `(("guix/graph.js" ,(local-file "../guix/graph.js"))
+ ("guix/d3.v3.js" ,(local-file "../guix/d3.v3.js")))
+
#:extensions dependencies
#:guile-for-build guile-for-build))