aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-02-19 18:04:03 +0100
committerRicardo Wurmus <rekado@elephly.net>2021-02-19 18:04:03 +0100
commit0d9c9502694984a800be9df3bf6ed518c3ce2aca (patch)
treeae53beae1e8ce597ee67b56339ca5069bd295e35
parentf3318fefe42d773297267ad940a2ec5893c5c094 (diff)
downloadguix-0d9c9502694984a800be9df3bf6ed518c3ce2aca.tar
guix-0d9c9502694984a800be9df3bf6ed518c3ce2aca.tar.gz
gnu: Add perl-want.
* gnu/packages/perl.scm (perl-want): New variable.
-rw-r--r--gnu/packages/perl.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index e279562b32..ca754868d1 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -8892,6 +8892,26 @@ straightforward and (perhaps someday) standard way. Spiffy borrows ideas from
other OO languages like Python, Ruby, Java and Perl 6.")
(license (package-license perl))))
+(define-public perl-want
+ (package
+ (name "perl-want")
+ (version "0.29")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/R/RO/ROBIN/Want-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1xsjylbxxcbkjazqms49ipi94j1hd2ykdikk29cq7dscil5p9r5l"))))
+ (build-system perl-build-system)
+ (home-page "https://metacpan.org/release/Want")
+ (synopsis "Generalization of wantarray")
+ (description "This module generalises the mechanism of the
+@code{wantarray} function, allowing a function to determine in some detail how
+its return value is going to be immediately used.")
+ (license license:perl-license)))
+
(define-public perl-statistics-basic
(package
(name "perl-statistics-basic")