aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2021-02-19 23:51:49 -0300
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-02-21 01:11:55 +0100
commit081d927409f0adc2ef32bdca055926a5b33cde2d (patch)
tree001ae1b330c814f6a413e8a1c802ccac5c119afd
parentf498823e7843379499d35ae397c38dc879fb9844 (diff)
downloadguix-081d927409f0adc2ef32bdca055926a5b33cde2d.tar
guix-081d927409f0adc2ef32bdca055926a5b33cde2d.tar.gz
gnu: Add python-pillow-simd.
* gnu/packages/python-xyz.scm (python-pillow-simd): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/python-xyz.scm35
1 files changed, 34 insertions, 1 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index c19429cff2..2ca4625c2c 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -82,7 +82,7 @@
;;; Copyright © 2020 Josh Holland <josh@inv.alid.pw>
;;; Copyright © 2020 Yuval Kogman <nothingmuch@woobling.org>
;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
-;;; Copyright © 2020 Vinicius Monego <monego@posteo.net>
+;;; Copyright © 2020, 2021 Vinicius Monego <monego@posteo.net>
;;; Copyright © 2020 Guy Fleury Iteriteka <gfleury@disroot.org>
;;; Copyright © 2020 Hendursaga <hendursaga@yahoo.com>
;;; Copyright © 2020 Malte Frank Gerdes <malte.f.gerdes@gmail.com>
@@ -5919,6 +5919,39 @@ a general image processing tool.")
((#:tests? _ #f) #f)))
(properties '((hidden? #t)))))
+(define-public python-pillow-simd
+ (package
+ (inherit python-pillow)
+ (name "python-pillow-simd")
+ (version "7.1.2")
+ ;; The PyPI tarball does not include test files.
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/uploadcare/pillow-simd")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0w11np4cybamry3jsg70x747c79zwjzfq0xiprfp6c186rd6nzp9"))))
+ (arguments
+ (substitute-keyword-arguments
+ (package-arguments python-pillow)
+ ((#:phases phases)
+ `(modify-phases ,phases
+ (add-after 'unpack 'make-tests-writable
+ (lambda _
+ (for-each make-file-writable (find-files "Tests"))
+ #t))))))
+ (inputs
+ `(("libraqm" ,libraqm)
+ ("libimagequant" ,libimagequant)
+ ,@(package-inputs python-pillow)))
+ (home-page "https://github.com/uploadcare/pillow-simd")
+ (synopsis "Fork of the Python Imaging Library (Pillow)")
+ (description "This package is a fork of Pillow which adds support for SIMD
+parallelism.")))
+
(define-public python-roifile
(package
(name "python-roifile")