aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEkaitz Zarraga <ekaitz@elenq.tech>2020-10-21 19:08:20 +0200
committerChristopher Baines <mail@cbaines.net>2020-10-24 20:26:16 +0100
commitf78681206680fd09f3d97c656c00cfcb79c40be3 (patch)
tree0913a1676217285f15f13414c649eac410bc3d4a
parent0b4ac3b17cb953a07f6222e870adeee669bcdd5b (diff)
downloadguix-f78681206680fd09f3d97c656c00cfcb79c40be3.tar
guix-f78681206680fd09f3d97c656c00cfcb79c40be3.tar.gz
gnu: Add python-scour.
* gnu/packages/python-xyz.scm (python-scour): New variable.
-rw-r--r--gnu/packages/python-xyz.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 2ac77ffde9..0fe4703a27 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -88,6 +88,7 @@
;;; Copyright © 2020 Joseph LaFreniere <joseph@lafreniere.xyz>
;;; Copyright © 2020 Tim Gesthuizen <tim.gesthuizen@yahoo.de>
;;; Copyright © 2020 Bonface Munyoki Kilyungi <bonfacemunyoki@gmail.com>
+;;; Copyright © 2020 Ekaitz Zarraga <ekaitz@elenq.tech>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1794,6 +1795,32 @@ human-friendly syntax.")
(define-public python2-schedule
(package-with-python2 python-schedule))
+(define-public python-scour
+ (package
+ (name "python-scour")
+ (version "038.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/scour-project/scour")
+ (commit
+ (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0rgiypb9ig8x4rl3hfzpy7kwnx1q3064nvlrv4fk0dnp84girn0v"))))
+ (propagated-inputs
+ `(("python-six" ,python-six)))
+ (build-system python-build-system)
+ (home-page "https://github.com/scour-project/scour")
+ (synopsis "Scour is an SVG optimizer/cleaner written in Python")
+ (description "The goal of Scour is to output a file that renderes
+identically at a fraction of the size by removing a lot of redundant
+information created by most SVG editors. Optimization options are typically
+lossless but can be tweaked for more agressive cleaning.")
+ (license license:asl2.0)))
+
(define-public python-mechanize
(package
(name "python-mechanize")